tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Filip Radlinski <fradlin...@gmail.com>
Subject System load creeping up with Tomcat + Lucene
Date Thu, 03 Mar 2005 17:21:20 GMT
Hi,

I'm using Tomcat and Lucene to build a search engine. I suspect this
is a Tomcat problem, but I can't be sure.

The system load and CPU usage by Tomcat keeps creeping up with
http-8081-Processor<n> threads becoming stuck in _hpiThreadHardSuspend
in libhpi.so. For example, I might get 10 or more threads similar to
what I pasted below.

Any ideas?

Thanks,
Filip

3XMTHREADINFO      "http-8081-Processor8" (TID:1007B400,
sys_thread_t:8B68F18, state:R, native ID:B30A2BB0) prio=5
NULL
3HPREGISTERS           Register Values
NULL                   ---------------
3HPREGVALUES            EAX : 00000101, EBX : 08B69208, ECX : 00000000
3HPREGVALUES            EDX : 08B68F18, ESI : 08B692CC, EDI : B30A03FC
3HPREGVALUES            EBP : B30A0404, ESP : B30A02FC, EIP : B72011B0
3HPREGVALUES            EFLAGS : 00000202
NULL
3HPNATIVESTACK         Native Stack of "http-8081-Processor8" PID 29178
NULL                   -------------------------
3HPSTACKLINE            _hpiThreadHardSuspend at B72011B0 in libhpi.so
3HPSTACKLINE            ?? at B71F45BB in libhpi.so
3HPSTACKLINE            ?? at B71F47C0 in libhpi.so
3HPSTACKLINE            ?? at B75CFE50 in libpthread.so.0

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message