tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Hosler" <chos...@ingham.org>
Subject configuring SSL on tomcat 5
Date Wed, 09 Feb 2005 15:15:30 GMT
I have a brand new tomcat 5 server that is up and running. I am also
brand new when it comes to Tomcat. I need to configure SSL on it . I
pulled the how to documents off the local server and I also pulled a
document off verisign website ID# VS26254 Which is for configuring a
tomcat ver4 server. I installed the SSL following the tomcat 5 how to
docs off the local server found under the documentation section. When I
try to verify that its running using the  https://localhost:8443 I get
page cannot be displayed. I have followed  all the steps in the
documentation but I think I see a couple of problems. When I ran the 

Keytool -genkey -alias tomcat -keyalg RSA -keystore
my_keystore_filename

it put the keystore file in the directory that I was running the
keytool.exe from which is the 
c:\j2sdk1.4.2_06\bin directory.  Also when I went to verisign to get
the chain certificate the default location that it wanted to save to was
under the tomcat\config directory but when I tried to run the 

keytool -import -alias root -keystore my_keystore_filename
-trustcacerts -file filename_of chain_cert
it could not find the chain cert but when I copied it to the same
directory  c:\j2sdk1.4.2_06\bin 
as the keytool.exe  it worked. Now  The document from versign talked of
the importance of getting everything into the directory that tomcat
expects it to be in . I believe that is the root problem. I have tried
to just copy the files to the tomcat\config and catalina  and localhost
dirs but no luck . Also the third and last problem that I could see is
when I edited the server.mxl file there was no classname section 
(<Connector className="org.apache.coyote.tomcat5.CoyoteConnector")
Just the port =8443 and all the rest .


<-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->

<Connector className="org.apache.coyote.tomcat5.CoyoteConnector"
           port="8443" minProcessors="5" maxProcessors="75"
           enableLookups="true" disableUploadTimeout="true"
           acceptCount="100" debug="0" scheme="https" secure="true";
           clientAuth="false" sslProtocol="TLS"/>


I removed the rem statement and tried it as was and also tried it by
adding the the classname statement  <Connector
className="org.apache.coyote.tomcat5.CoyoteConnector"

which also failed .So as you can see I have a lot of questions . Any
help would be great.
Right now I get no errors at all. I have turned off the friendly errors
in internet explorer but most of the time get the page can not be
displayed some of the time it looks like its trying to work I see the
yellow padlock  in the lower right of the browser but it just sits there
trying to pull up something and it just sit there on a empty page,
trying to pull up something but nothing ever comes of it.
Thanks again for any help

 




Christopher W. Hosler
Network Administrator 
Ingham County MIS Department
Email  chosler@ingham.org 
As water reflects the face 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message