tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vic <...@friendvu.com>
Subject Re: tomcat CPU utilization pegged...total CPU only 50%
Date Fri, 04 Feb 2005 05:09:11 GMT
You could be DB bound or LAN bound.
What is the switch telling you LAN utilization is?
What is the DB stress test telling you?
.V

Kevin Williams wrote:

>Hello,
>
> 
>
>I am trying to performance test an application running Tomcat with
>Apache w/SSL (connected using mod_proxy).  The OS is Windows Server
>2003.
>
> 
>
>The test I am running is simulating a user logging into the application
>(using JMeter for the testing framework).  Increasing the number of
>users from 1, 2, 3, 4,5 the total CPU utilization jumps considerably.
>After 5 users the CPU utilization hits 50% for a second and then
>drops...When simulating 10 users, the CPU hits50% for a few seconds and
>drops back down, the more users, the longer the CPU is pegged at 50%.
>My question is why is tomcat only using 50% of the CPU?  Seeing the CPU
>grow significantly with each user, and then peg out for longer periods
>of time with an increased user load indicates that the CPU is the choke
>point.  Using performance monitor, the Tomcat % Processor Time pegs out
>at 100% for the duration that total CPU utilization is at 50%.  Is there
>a configuration option that I am unaware of to allow tomcat to use more
>CPU?
>
> 
>
>Thanks in advance!
>
> 
>
>Kevin
>
>
>  
>


-- 
Forums, Boards, Blogs and News in RiA <http://www.boardVU.com>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message