tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Russell" <>
Subject Re: Apache/Win32 + mod_jk problem
Date Thu, 10 Feb 2005 15:01:14 GMT
Thanks Andoni, that appeared to work.

However, I don't really understand why.

I had actually thought that this might be related to EAPI, which I 
understand is the primary difference (apart from mod_ssl itself) between 
Apache without SSL and Apache with SSL. However, I couldn't find any 
mention of this in the JK docs, nor in the Apache or Tomcat docs, and 
given that there was no option to download an EAPI/SSL Apache 1.3.33, and 
no option to download a non-EAPI/SSL mod_jk 1.2.8, I presumed that they 
were compatible. Certainly more likely than this one, which is allegedly 
for Apache 1.3.31, and is an old version of mod_jk anyway.

Does this mean that there is no binary Win32 Apache 1.3.33 and mod_jk 
1.2.8 that can be downloaded that work with each other? This seems a 
little odd to me... Surely I'm missing something?


Richard Russell 
Deutsche Bank AG London 
Global Markets Customer Solutions
Office: +44 20 7545 8060
Mobile: +44 79 0661 2237

Andoni <>
02/10/2005 02:46 PM
Please respond to "Tomcat Users List"
        To:     Tomcat Users List <>
        Subject:        Re: Apache/Win32 + mod_jk problem


Try using the version of mod_jk.dll which you can find here:


Don't forget to change the line which refers to it in httpd.conf. Also 
forget to rename it to mod_jk.dll.

I think the .so version is only for Apache with SSL built in.


----- Original Message ----- 
From: "Richard Russell" <>
Newsgroups: gmane.comp.jakarta.tomcat.user
Sent: Thursday, February 10, 2005 12:31 PM
Subject: Apache/Win32 + mod_jk problem

> I cannot run apache with mod_jk on Windows XP Pro + SP1. I have had no
> troubles doing the same thing with multiple versions of Apache & mod_jk 
> multiple versions of Solaris, Linux and FreeBSD. This is, however, my
> first attempt at mixing Windows with real software :-S
> I'm running the following versions:
> Apache          1.3.33  ${APACHE_MIRROR}/httpd/binaries/win32/
> apache_1.3.33-win32-x86-no_src.exe
> mod_jk          1.2.8
> ${APACHE_MIRROR}/jakarta/tomcat-connectors/jk/binaries/win32/
> MD5SUMs:
> afb8924ec7b368e132fbed5f28ad6f3b apache_1.3.33-win32-x86-no_src.exe
> ea33398544fe6ecdccecf81307c86211
> The Apache one agrees with that listed on the website, but I can't find 
> md5sum listed for mod_jk...
> -----
> C:\apache>apache
> Syntax error on line 194 of c:/apache/conf/httpd.conf:
> Cannot load c:/apache/modules/ into server: (127) The specified
> procedure could not be found:
> Note the errors or messages above, and press the <ESC> key to exit. 
> C:\apache>grep -ni jk conf\httpd.conf
> 194:LoadModule jk_module modules/
> 242:AddModule mod_jk.c
> -----
> The mod_jk file has been renamed "" and placed in the
> "c:/apache/modules" directory. I have tried with it renamed as .dll and 
> makes no difference.
> I've also tried introducing intentional typos in the LoadModule command
> (eg LoadModule jk_module modules/, and found that this
> changed the error message to something like "module not found", so it's
> definitely finding the module.
> I'm somewhat stuck here. The only documentation that mentions this error
> is for mod_ssl, and it suggests that I have an error in the AddModule
> line... Which I don't think I do...
> Could someone advise?
> Cheers
> Richard Russell
> Deutsche Bank AG London
> Global Markets Customer Solutions
> Office: +44 20 7545 8060
> Mobile: +44 79 0661 2237

To unsubscribe, e-mail:
For additional commands, e-mail:

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message