tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Russell" <richard.russ...@db.com>
Subject Apache/Win32 + mod_jk problem
Date Thu, 10 Feb 2005 12:31:54 GMT
I cannot run apache with mod_jk on Windows XP Pro + SP1. I have had no 
troubles doing the same thing with multiple versions of Apache & mod_jk on 
multiple versions of Solaris, Linux and FreeBSD. This is, however, my 
first attempt at mixing Windows with real software :-S

I'm running the following versions:

Apache          1.3.33  ${APACHE_MIRROR}/httpd/binaries/win32/ 
apache_1.3.33-win32-x86-no_src.exe 
mod_jk          1.2.8   
${APACHE_MIRROR}/jakarta/tomcat-connectors/jk/binaries/win32/
mod_jk-1.2.8-apache-1.3.33-eapi.so 

MD5SUMs:
afb8924ec7b368e132fbed5f28ad6f3b        apache_1.3.33-win32-x86-no_src.exe
ea33398544fe6ecdccecf81307c86211        mod_jk-1.2.8-apache-1.3.33-eapi.so

The Apache one agrees with that listed on the website, but I can't find an 
md5sum listed for mod_jk...

-----
C:\apache>apache
Syntax error on line 194 of c:/apache/conf/httpd.conf:
Cannot load c:/apache/modules/mod_jk.so into server: (127) The specified 
procedure could not be found:

Note the errors or messages above, and press the <ESC> key to exit.  29...
C:\apache>grep -ni jk conf\httpd.conf
194:LoadModule jk_module modules/mod_jk.so
242:AddModule mod_jk.c
-----

The mod_jk file has been renamed "mod_jk.so" and placed in the 
"c:/apache/modules" directory. I have tried with it renamed as .dll and it 
makes no difference.

I've also tried introducing intentional typos in the LoadModule command 
(eg LoadModule jk_module modules/mod_foojk.so), and found that this 
changed the error message to something like "module not found", so it's 
definitely finding the module.

I'm somewhat stuck here. The only documentation that mentions this error 
is for mod_ssl, and it suggests that I have an error in the AddModule 
line... Which I don't think I do...

Could someone advise?

Cheers

Richard Russell 
Deutsche Bank AG London 
Global Markets Customer Solutions
Office: +44 20 7545 8060
Mobile: +44 79 0661 2237
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message