tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Richard Mixon (qwest)" <rnmi...@qwest.net>
Subject RE: Tomcat 5.5.7 webapp not reload after META-INF/context.xml change
Date Mon, 14 Feb 2005 03:30:40 GMT
Tevor,

Not sure if I have much to add, so much as just clarifying what you are
asking. Its of interest to me also.

If you are using the tomcat-deployer app, then file
"tomcat/webapps/<your-webapp>/META-INF/context.xml" normally gets
deployed to "tomcat/conf/Catalina/localhost/<your-webapp>.xml". I
realize that the "tomcat/conf/context.xml" specifies that
META-INF/context.xml is a watched resource and if changed it should
reload the webapp. But are you also expecting it to redeploy
META-INF/context.xml to conf/Catalina/localhost/<your-webapp>.xml ?? I
cannot see how that could happen.

OTOH, this may just reflect my rather narrow use of Tomcat 5.x - always
using tomcat-deployer to deploy my applications. Maybe someone else that
know more can comment and we will both learn a bit.

HTH - Richard

-----Original Message-----
From: Trevor Baker [mailto:amoebaworks@yahoo.ca]
Sent: Sunday, February 13, 2005 7:30 PM
To: tomcat-user@jakarta.apache.org
Subject: Tomcat 5.5.7 webapp not reload after META-INF/context.xml
change


Hi,

I have an unpacked ROOT webapp and if I change the
web.xml for it, the webapp gets reloaded. However if I
change the META-INF/context.xml for it, it doesn't get
reloaded. It's a WatchedResource too like web.xml. All
I'm doing is changing a context-param value in
context.xml (as a trivial example to explain my
issue).

When I change context.xml, I get this in the log:
Feb 13, 2005 6:11:39 PM
org.apache.catalina.startup.HostConfig checkResources
INFO: Reloading context []

So it looks like it should be reloaded, but it
doesn't.

In:
http://jakarta.apache.org/tomcat/tomcat-5.5-doc/config/context.html

There is:
<snip>
WatchedResource - The auto deployer will monitor the
specified static resource of the web application for
updates, and will reload the web application if is is
updated. The content of this element must be a string.
</snip>

So I'm not dreaming.

I've also tried restaring the webapp with the manager
webapp and still no change.

Anyone else have the same issue? Am I doing something
wrong? Otherwise I'm going to enter it as a bug.

thanks,
Trev

______________________________________________________________________
Post your free ad now! http://personals.yahoo.ca

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message