tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LERBSCHER Jean-Pierre <jean-pierre.lerbsc...@cofiroute.fr>
Subject RE : Jass Login Module not found
Date Fri, 18 Feb 2005 08:21:43 GMT
Hi Sara,
Your login module library (and all it's dependencies) must be deployed in
common/lib if you setup JAASRealm with your own component.

-----Message d'origine-----
De : Sara Blauman [mailto:sara.blauman@alcatel.com] 
Envoyé : jeudi 17 février 2005 23:22
À : tomcat-user@jakarta.apache.org
Objet : Jass Login Module not found

Hi,

I am running Tomcat 5.5.4 and am wanting to use Jaas with my own custom
login module. My Jaas config file is being found but my login module is not.
If I run with one of Sun's login modules everything works fine so I think
that my Jass configuration file, JASSRealm specification in my app.xml file,
and -D options are ok. 

I wondered if my login module was even being loaded so I instanciated it in
a part of my application code to verify and sure enough it is there, but,
when it is called from the LoginContext it isn't found. I am trying this
from an Mbean and also a servlet and the results are the same. I am not
running a security manager. I tried putting the login module in a separate
jar from the rest of my application as well as having it in the same jar but
the results are the same. 

Does anyone have any ideas?

Regards,
Sara


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message