tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Caldarale, Charles R" <Chuck.Caldar...@unisys.com>
Subject RE: Startup
Date Sun, 27 Feb 2005 15:51:09 GMT
> From: Nikola Milutinovic [mailto:Nikola.Milutinovic@ev.co.yu]
> Subject: Re: Startup
> 
> I didn't say it cannot work. It can, but it has been stripped of APIs 
> that are provided with 1.5.0, which are not present in 1.4.2. 
> Which is why you need that "compat.zip", right?

The three jars in the compat download are jmx, xercesImpl, and xml-apis.  The 5.0.x Tomcat
releases include all of these; they were left out of 5.5.x since Sun now releases them in
the 1.5 JRE, and having duplicates in the Tomcat libraries might cause problems and would
create an unnecessarily larger download for 1.5 users.  Note that the 5.5.x branch does not
utilize any 1.5 JRE or language features, and the newly included Java compiler - which is
why you only need a JRE, not a JDK - can't handle 1.5 source (but it sure is fast).

> I'm not sure if there are any other improvements over 5.0.x series, 
> other than that.

As I said before - performance.  Check Peter Lin's results, recently published in this list.

 - Chuck


THIS COMMUNICATION MAY CONTAIN CONFIDENTIAL AND/OR OTHERWISE PROPRIETARY MATERIAL and is thus
for use only by the intended recipient. If you received this in error, please contact the
sender and delete the e-mail and its attachments from all computers.

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message