tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ritu Kedia <RKe...@saba.com>
Subject Content-Type removed from the Http Response when file is accessed through Tomcat Connector
Date Tue, 08 Feb 2005 13:51:06 GMT
Hello All,

I am facing a problem with the Content-Type getting removed from the Http
Response when accessing a binary file packaged in a WAR file through a Web
Server (IIS 5.0 or Apache 2.0).

My web.xml has the following mime-type mapping:
	<mime-mapping>
		<extension>msi</extension>
		<mime-type>application/x-msi</mime-type>
	</mime-mapping>

I have a .msi file packaged inside a WAR which is deployed on JBoss-Tomcat
(Tomcat-4.1.x). When I access this msi file through IE browser the browser
reads the contents of the msi and displays in the borwser instead of
prompting for saving this file.

I have tested accessing this file directly from the port 8080, which works
fine. It appears that Tomcat connector which is intercepting the requests to
and from the Web Server is somehow removing the Content-Type from the Http
Response. 

I have tested fronting Tomcat with IIS 5.0 as well as Apache 2.0. The
problem persists on both configurations. 

Could anyone please point out what am I doing wrong or whether this is a
known issue?

Thanks,
Ritu


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message