tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Andersson <andr...@travelstart.se>
Subject Re: Using native and ld_library_path
Date Tue, 01 Feb 2005 19:12:56 GMT
Caldarale, Charles R wrote:

> Take a look at:
> http://java.sun.com/docs/books/tutorial/native1.1/stepbystep/step1.html

Hi again. I did take a look but nothing helped me there and I still need 
  help.

My guess is that tomcat has some restrictions when it comes to loading 
native code.

I have several native libraries. One of them is loaded and executed from 
my code, the rest is used by the first one.

What confuses me is that this works on my tomcat on windows but not 
linux. It also works on a standalone program on that same linux machine. 
But not my tomcat on linux.

I've tried putting the libraries in /usr/lib. That works for my 
standalone but not tomcat.

I've tried setting -Djava.library.path in catalina.sh, that doesn't work.

When printing System.getProperties().get("java.library.path") I get the 
right paths but still I get the "unsatisfied link error". Is there more 
debug information available in some way?

This is really frustrating since it shouldn't be this hard :)

I appreciate any help.

-- 
Andreas Andersson
IT Dept.
Travelstart Nordic
andreas@travelstart.se
http://www.travelstart.se

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message