tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sara Blauman" <>
Subject Jass Login Module not found
Date Thu, 17 Feb 2005 22:22:03 GMT

I am running Tomcat 5.5.4 and am wanting to use Jaas with my own custom
login module. My Jaas config file is being found but my login module is not.
If I run with one of Sun's login modules everything works fine so I think
that my Jass configuration file, JASSRealm specification in my app.xml file,
and -D options are ok. 

I wondered if my login module was even being loaded so I instanciated it in
a part of my application code to verify and sure enough it is there, but,
when it is called from the LoginContext it isn't found. I am trying this
from an Mbean and also a servlet and the results are the same. I am not
running a security manager. I tried putting the login module in a separate
jar from the rest of my application as well as having it in the same jar but
the results are the same. 

Does anyone have any ideas?


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message