tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Parsons Technical Services" <parsonstechni...@earthlink.net>
Subject Re: Realm + PDF + Internet Explorer
Date Fri, 04 Feb 2005 14:50:11 GMT
Yes.

I have not attempted a fix as of yet. Was planning to try the link provided 
by Wendy as well as a twist on the uri. Mine now calls the servlet name. I 
was going to amend .pdf to it to see if that would help.

I wonder, is it possible to set the response.setContentType() twice? Set it 
to html, send a blank page, change to application/pdf and send the document.


Doug

----- Original Message ----- 
From: "Milazzo, Michael A HQISEC" <Michael.Milazzo@us.army.mil>
To: "Tomcat Users List" <tomcat-user@jakarta.apache.org>
Sent: Friday, February 04, 2005 9:28 AM
Subject: RE: Realm + PDF + Internet Explorer


>I have a similar issue.  I am running Tomcat 5.0.x and Apache 1.3.x using
> the mod_jk connector over SSL (Apache handling all the SSL).  I have a
> servlet that is supposed to open a PDF on the server and send it to a
> requesting client (using the HttpServletRequest object's output stream). 
> IE
> 6 tells me that it can't download the internet site and the requested
> resource is either not found or not available.  I know the files are there
> and no exceptions are being thrown on the server.
>
> Anyone else encountered this issue?
>
> Thanks,
>
> Mike
>
> -----Original Message-----
> From: Kalyan Inuganti [mailto:kinuganti@gmail.com]
> Sent: Thursday, February 03, 2005 10:36 AM
> To: Tomcat Users List
> Subject: Re: Realm + PDF + Internet Explorer
>
>
> Gracie,
> IE has a setting that does not let you open PDFs being served over
> SSL. You can configure IE to not do this:
>
> Tools -> Internet Options -> Advanced -> Security ->
>
> Uncheck the "Do Not Save Encrypted Pages to Disk" checkbox if its checked.
>
> This should not have anything to do with Tomcat though. Hope that helps.
>
> Thanks,
> Kalyan
>
> On Thu, 03 Feb 2005 10:24:34 -0700, Wendy Smoak <java@wendysmoak.com> 
> wrote:
>> From: "Graice Marques" <graicem@gmail.com>
>>
>> > I'm having a problem with Internet Explorer. I have a web application
>> > running in Tomcat that generate some PDF reports. When I add a tomcat
>> > security realm to my webapp and run it in IE I can't open my PDF
>> > reports.
>>
>> I don't know if this is the same problem, but at least one version of IE
>> wouldn't display non-HTML content after a form POST over SSL.  Here's a
>> workaround:
>>
>> http://wiki.wendysmoak.com/cgi-bin/wiki.pl?NonsecureContent
>>
>> --
>> Wendy Smoak
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message