tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Frank W. Zammetti" <fzli...@omnytex.com>
Subject Re: JSP compilation problem
Date Sun, 02 Jan 2005 19:46:49 GMT
Very interesting... Switching to JDK 1.4.2 solved the problem.  I didn't 
even do an uninstall/reinstall... I always install my SDK to c:\java, so 
all I did was rename it and copy the directory over from another PC, so 
any paths and registry settings should still be valid, there's just an 
older version in it's place.  I made sure to delete the Tomcat work 
folder for the app, started up Tomcat and tried it, everything worked 
fine... JSP class was generared, servlet compiled, and page came up, no 
problem.

So... Is there actually a problem using JDK 5.0 with Tomcat 5.0.29?  If 
so, what version of Tomcat is OK with 5.0? (assuming any are, which I DO 
assume).  Or is this just some sort of fluke situation?

In any case, my problem is solved, and that was the resolution.

-- 
Frank W. Zammetti
Founder and Chief Software Architect
Omnytex Technologies
http://www.omnytex.com

Ryan Stewart wrote:
> First, I apologize if I came of sounding rude before. As an infrequent visitor to this
list, I wasn't aware that you are a frequent contributor. I also don't seem to have received
the other reply you mention. My next thought is that you might have two versions of Java installed.
If so, which version is Tomcat using? Are you sure you compiled the servlet with the same
one?
> 
> -----Original Message-----
> From: "Frank W. Zammetti"<fzlists@omnytex.com>
> To: "Tomcat Users List"<tomcat-user@jakarta.apache.org>
> Date: Sat Jan 01 07:22:09 PST 2005
> Subject: Re: JSP compilation problem
> 
> 
>>I did not post twice Ryan.  If two posts appeared, it is the same 
>>problem with the list processor that we've been seeing for weeks now.
>>
>>I did post a reply however... I tried your suggestion and manually 
>>compiled.  I have NO classpath variable in the environment (I thought 
>>this might have been a classpath issue, and I guess it could still be, 
>>but I don't see how at this point).  I manually put servlet-api.jar, 
>>jsp-api.jar and jasper-runtime.jar in /tomcat/common/lib on the 
>>classpath and compiled, and it compiles cleanly.  So the problem would 
>>not appear to be a problem with the generated servlet.  Any other ideas?
>>
>>Thank you!
>>
> 
> 
> 
> ___________________________________________________
> Check-out GO.com
> GO get your free GO E-Mail account with expanded storage of 6 MB!
> http://mail.go.com
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> 
> .
> 




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message