tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phil Steitz <p...@steitz.com>
Subject Re: Can't load server.xml message
Date Sun, 02 Jan 2005 01:50:31 GMT
Sean Schofield wrote:
> I am an experienced Tomcat user who is all of a sudden having trouble
> running Tomcat on my home machine.  I am running Tomcat 5.0.28 and I
> get a Null Pointer when trying to start Tomcat.
> 
> I have JAVA_HOME and CATALINA_HOME configured.
> 
> The very first line in the output says "Can't load server.xml"
> (actually the second line says the same thing as well.)  I tried
> chaning to the minimal server.xml as well but no luck.
> 
> The stack trace seems to indicate a NullPointer exception at
> Catalina.await line 619.  I have tried looking this up on the mailing
> lists, but incredibly, nobody seems to have experienced this problem!
> 
> Anyways, any insight that could be provided would be greatly
> appreciated.  I've never had this problem before ...

I had this problem once when I inadvertently moved server.xml from 
/conf.  I think the error message means what it says -- it cant't read 
the file.  Are you sure it is in the right place and the user running tc 
has permission to read the file?

Phil
> 
> TIA,
> 
> sean
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message