tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andy Kriger <andy.kri...@gmail.com>
Subject bizarre authentication problem
Date Mon, 24 Jan 2005 21:24:23 GMT
I have an Tomcat server on an internal network configured to require
basic authentication. This works fine when I use IE or Java code to
access a site, but when I try to access the site using Firefox, the
user/password is never accepted. I have packet sniffed the GET calls
from both IE and Firefox and the Authorization header is the same for
both. I can access the Tomcat Manager using basic auth and external
sites with auth so it's not entirely broken. Tomcat has
maxKeepAliveRequests set to 1 (to deal with a .NET SOAP interop
problem) - that's the only oddball config in Tomcat.

I realize this is more likely a Firefox problem than a Tomcat one, but
I'm wondering if anyone has seen behavior like this.

This is the diff between the IE HTTP headers (<) and the Firefox HTTP
headers (>)...
< Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg,
application/x-shockwave-flash, application/vnd.ms-excel,
application/vnd.ms-powerpoint, application/msword, */*
< Accept-Language: en-us
< Accept-Encoding: gzip, deflate
< User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0;
Feedreader; .NET CLR 1.0.3705; .NET CLR 1.1.4322)
7c3,9
< Connection: Keep-Alive
---
> User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.5) Gecko/20041107
Firefox/1.0
> Accept: text/xml,application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
> Accept-Language: en-us,en;q=0.5
> Accept-Encoding: gzip,deflate
> Accept-Charset: ISO-8859-1,utf-8;q=0.7,*;q=0.7
> Keep-Alive: 300
> Connection: keep-alive

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message