tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Ricker <bric...@brick.net>
Subject Re: Jdeveloper 3.2.3 -> Tomcat 5.5 migration: Inordinate delay in JSPs returning XML
Date Fri, 14 Jan 2005 12:44:25 GMT
Rule number one when working with Internet Exploder: try other  
browsers. I usually try Netscape, Mozilla and Firefox. If they work on  
those browsers, you are dealing with (imagine this): an IE bug.

Thing is a piece of.....if I have to deal with one more IE specific bug.

Ben Ricker


On Jan 13, 2005, at 10:49 PM, Rajeev Singh wrote:


> Updates - setting Internet Explorer to use HTTP 1.0 makes the problem  
> go
> away. I still do not understand why this should happen and what can I  
> do to
> have the 1.1 mass of clients work with this correctly. Any insights  
> would be
> much appreciated.
>
> FYI - the header seen by the JSP page is:
> //inase of 1.1
> Here are the header
> Header:accept*/*,Header:--------------------  
> -------,Header:user-agentMozill
> a/4.0 (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR
> 1.0.3705),Header:host127.0.0.1:8080,Header:connectionKeep- 
> Alive,Header:cooki
> eWTGBID=e1ujo01n
>
> //incase of 1.0
> Header:accept*/*,Header:accept-languageen-us,Header:user- 
> agentMozilla/4.0
> (compatible; MSIE 6.0; Windows NT 5.0; .NET CLR
> 1.0.3705),Header:hostlocalhost: 
> 8080,Header:--------------------,Header:cooki
> eWTGBID=e2jl7opw; _tpc=_t%3D1105675240385%26_l%3D0
>
> --------------------------------
> Rajeev Singh
> Intelliplanner Software Systems, Inc.
> 203-483-4279(O)
> 203-558-3224(C)
> www.intelliplanner.com , www.ipssi.com
>
> ------------------------------------
> This mail contains proprietary and confidential materials. Please  
> destroy if
> received in error and notify the sender
>
> -----Original Message-----
> From: Rajeev Singh [mailto:rajeev@ipssi.com]
> Sent: Thursday, January 13, 2005 10:04 PM
> To: tomcat-user@jakarta.apache.org
> Subject: Jdeveloper 3.2.3 -> Tomcat 5.5 migration: Inordinate delay in
> JSPs returning XML
>
>
> I am going nuts trying to figure out why:
> An application created using Jdeveloper 3.2.3 (on Windows 2000). Some
> pages send XML as response. When using Jdev, JSP/Web-to-go server
> everything is fine. Now trying to migrate to TomCat 5.5. For pages that
> return XML, I am noticing a rather 'hang' like behaviour. As if client
> is waiting for something: Moreover when using telnet no such problem
> exists - the response comes boom. (Not sure how to look at header - I
> do not see any headers in the response in telnet)
>
> I put a time stamp at beginning and end of my processing. Elapsed time
> is 20ms. Page size < 500 b. All done locally. Browser (Internet
> Explorer) takes about 9s to display the XML. Page is buffered (32K,
> though doesn't help, autoflush on). I even tried with  
> response.SetHeader
> (Connection, close) no luck.
>
> Similarly my (C++) client makes a bunch of call to such JSP pages
> returning XML. Each time the processing supposed to happen, happens in
> 20-100ms. But the client seems to be 'waiting': gaps between timestamp
> for next request spans more than 10-30s. The client uses Microsoft's
> IXMLHttpRequest (MSXML v3). Any ideas what could be happening?
>
> Also any reason for cookies not be written by Tomcat (the Jdev does
> write that)
>
> mucho gracias
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message