tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thomas Tinnes <>
Subject [FIXED] Mod_JK 1.2.8, gcc 3.4.3 on Linux RH ES3 - compile error
Date Wed, 05 Jan 2005 21:45:00 GMT

Just a follow up to let you know how this got resolved.
First, thanks to all my respondents. It all helped.

I tried using ./, but got the same result. The Rosetta Stone
came from Mladden when it was pointed out that the second value of
-DHAVE_APR hadn't a "-I" before the second value string.

I traced this back to the config which got these values by querying the
the value of which is:
[root@host]# /usr/sbin/apxs -q APR_INCLUDEDIR

This gave value to APR_INCLUDEDIR, which begat APRINCLUDEDIR, which 
-DHAVE_APR ${APRINCLUDEDIR} which begat the problem:

The solution was to go to each Makefile (./common, ./apache-1.3, 
./apache-2.0) and just vi and add the missing "-I".

It seems to have compiled and installed fine.

Thanks, again, to all.


On Jan 4, 2005, at 9:16 PM, Thomas Tinnes wrote:

> Hello,
> Getting a compile error I'm having trouble understanding.
> Here's my setup:
> Installing jakarta-tomcat-connectors-1.2.8-src.tar.gz from the Jakarta 
> site.
> On a Linux Red Hat Enterprise 3 (Taroon) on an i386 arch & i686 cpu.
> I'm using gcc version 3.4.3 20041212 (Red Hat 3.4.3-10).
> There's Apache 2.0.46-44 running with source objects in
> /usr/src/redhat/BUILD/httpd-2.0.46.
> I unzip and untar and cd to 
> jakarta-tomcat-connectors-1.2.8-src/jk/native
> and do "./configure --with-apxs=/usr/sbin/apxs".
> The config runs without errors but when I run "make", I get an "Error 
> 1":
> make[1]: Entering directory 
> `/tmp/jk/jakarta-tomcat-connectors-1.2.8-src/jk/native/common'
> /bin/sh /usr/bin/libtool --silent --mode=compile gcc 
> -I/usr/include/httpd -g -O2 -O2 -g -pipe -march=i386 -mcpu=i686 
> -DSSL_EXPERIMENTAL_ENGINE -I/usr/kerberos/include -pthread -DHAVE_APR 
> -I/usr/src/redhat/BUILD/httpd-2.0.46/prefork/srclib/apr/include 
> /usr/src/redhat/BUILD/httpd-2.0.46/srclib/apr/include -g -O2 -DLINUX=2 
> -D_GNU_SOURCE -I /usr/local/java/include -I /usr/local/java/include/ 
> -c jk_ajp12_worker.c
> gcc: /usr/src/redhat/BUILD/httpd-2.0.46/srclib/apr/include: linker 
> input file unused because linking not done
> cc1: /usr/src/redhat/BUILD/httpd-2.0.46/srclib/apr/include: No such 
> file or directory
> make[1]: *** [jk_ajp12_worker.lo] Error 1
> make[1]: Leaving directory 
> `/tmp/jk/jakarta-tomcat-connectors-1.2.8-src/jk/native/common'
> make: *** [all-recursive] Error 1

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message