tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Parsons Technical Services" <parsonstechni...@earthlink.net>
Subject Re: Missing application web.xml
Date Thu, 20 Jan 2005 23:44:40 GMT
Not an expert in this area (don't use ant) but two things. Try to unpack the 
war file and read the xml file. It may be there but is corrupt.

You can test # 2 by renaming the file, copy it to the directory and then 
renaming it.

Just some thoughts.

Doug


----- Original Message ----- 
From: <eph1v3t8-tomcat6412@mailblocks.com>
To: <tomcat-user@jakarta.apache.org>
Sent: Thursday, January 20, 2005 6:25 PM
Subject: Missing application web.xml


>I am using Tomcat 5.5(.4?) on a PC.  Periodically, when I copy a WAR file 
>into the webapps directory, the auto-deployment fails, and I get the 
>following error in my stdout.log:
>
> INFO: Missing application web.xml, using defaults only 
> StandardEngine[Catalina].StandardHost[localhost].StandardContext[/kcStudy]
>
> I build the WAR file using ant, so I know I am building the WAR file the 
> same each time, even though at least half of the time everything works 
> fine.  When the error happens, I have double-checked the WAR file 
> (kcStudy.war, in this case) and it does indeed contain web.xml.   Also, in 
> the unpacked "kcStudy" folder, there is a great deal missing besides 
> web.xml.  This leads me to conclude that either:
>
> 1) the deployment was interrupted for some reason.
>
> or
>
> 2) the auto-deployment kicked in *while* the WAR file was being copied 
> into webapps, and tried to read it before it was all there.
>
> I have tried working around this by using the manager servlet, but can get 
> the same error there as well.
>
> Does anyone have a solution for this?
>
> Thanks,
>
> Paul Lynch
> (eph1v3t8 @ mailblocks.com)
>
> ----------------------------------------------
> Mailblocks - A Better Way to Do Email
> http://about.mailblocks.com/info
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message