tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ian Brandt <...@ianbrandt.com>
Subject Re: Won't deploy to root context even with Context path=""?
Date Tue, 07 Dec 2004 16:27:40 GMT

Hi Yoav,

Thanks for the reply.  I changed my server.xml as follows:

<Host name="localhost" debug="9" appBase="webapps"
        unpackWARs="true" autoDeploy="false"
        xmlValidation="false" xmlNamespaceAware="false">

I restarted, but no change:

Dec 7, 2004 7:56:37 AM org.apache.catalina.core.StandardHostDeployer install
INFO: Installing web application at context path /myapp from URL 
file:/Applications/jakarta-tomcat-5.0.28/webapps/myapp


I searched but could not find any other Host declarations, nor any 
instances of 'autoDeploy' in my conf directory.  I tried setting every 
instance of debug in server.xml to "9", but upon restart I'm not getting 
any more output in logs/catalina.out than I did with debug="0".  I tried 
removing server.xml altogether to see if was being ignored for some 
reason, but then tomcat failed to start.

Anything else I could try?

Thanks Again,

Ian


Shapira, Yoav wrote:
> Hi,
> Because you've probably left autoDeploy on for your Host.
> 
> Yoav Shapira http://www.yoavshapira.com
>  
> 
> 
>>-----Original Message-----
>>From: news [mailto:news@sea.gmane.org] On Behalf Of Ian Brandt
>>Sent: Monday, December 06, 2004 7:14 PM
>>To: tomcat-user@jakarta.apache.org
>>Subject: Won't deploy to root context even with Context path=""?
>>
>>
>>Hi,
>>
>>I'm running 5.0.28.  I'm using the default
> 
> $CATALINA_HOME/conf/server.xml.
> 
>> I have removed the ROOT and example webapps leaving only admin,
> 
> manager
> 
>>(in server/webapps), and myapp (expanded into $CATALINA_HOME/webapps).
> 
> In
> 
>>$CATALINA_HOME/conf/Catalina/localhost/myapp.xml I have specified my
>>Context path="".  When I start the server I get:
>>
>>INFO: Installing web application at context path /myapp from...
>>
>>I then also get the apparently infamous:
>>
>>[myapp] WARN [main] SettingsFactory.buildSettings(96) | Could not
> 
> obtain
> 
>>connection metadata
>>org.apache.commons.dbcp.SQLNestedException: Cannot create JDBC driver
> 
> of
> 
>>class '' for connect URL 'null'
>>
>>When I change the Context path back to ="myapp" in myapp.xml the JDBC
>>error goes away, so I'm assuming there's some sort of context mismatch
>>when I specify "" but Tomcat deploys to /myapp anyway.
>>
>>So my question is why might Tomcat deploy my webapp to the context path
>>/myapp as opposed to the root context when I specify path=""?
>>
>>Thanks!
>>
>>Ian
>>
>>
>>---------------------------------------------------------------------
>>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 
> 
> 
> 
> This e-mail, including any attachments, is a confidential business communication, and
may contain information that is confidential, proprietary and/or privileged.  This e-mail
is intended only for the individual(s) to whom it is addressed, and may not be saved, copied,
printed, disclosed or used by anyone else.  If you are not the(an) intended recipient, please
immediately delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message