tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From LERBSCHER Jean-Pierre <jean-pierre.lerbsc...@cofiroute.fr>
Subject RE : Problem with JAAS
Date Thu, 02 Dec 2004 10:36:48 GMT
Use tomcat env JAVA_OPTS=-Djava.security.auth.login.config=<java config
file> to declare your login module.

-----Message d'origine-----
De : Julian Templeman [mailto:julian.templeman@gmail.com] 
Envoyé : jeudi 2 décembre 2004 09:56
À : tomcat-user@jakarta.apache.org
Objet : Problem with JAAS

I'm evaluating an ISP that uses Tomcat to host webapps, and am running
into a security problem.

Any webapp that uses FORM authentication triggers an error from JAAS,
saying that it can't find a login configuration. I'm certainly not
using JAAS, and have just been adding users to the tomcat-users.xml
file. I've been able to confirm that this happens with even the
simplest apps.

Can anyone give me any idea of what's going on here? My guess is that
somehow Tomcat is configured to use JAAS by default, but since I've
not used JAAS before now, I'm not sure where to look...

Thanks,

julian
in london

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message