tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Williams, Allen" <awill...@harris.com>
Subject RE: FactoryConfigurationError: Couldn't find SAXParserImpl
Date Mon, 06 Dec 2004 19:37:26 GMT
Thanks!  I'll try again and give that a shot...

--------------------------------
Thanks,
Allen


> -----Original Message-----
> From: D. Stimits [mailto:stimits@comcast.net] 
> Sent: Monday, December 06, 2004 2:25 PM
> To: Tomcat Users List
> Subject: Re: FactoryConfigurationError: Couldn't find SAXParserImpl
> 
> 
> Williams, Allen wrote:
> > I get an error similar to this everytime I try to start 
> Tomcat, and it 
> > won't start.  Does anyone have any idea why this is?  To 
> the best of 
> > my knowledge, the jar file are correctly in the path and there is a 
> > SAXParserImpl in one of them. How does Tomcat try to find these?  
> > Could it be some sort of versioning problem?
> 
> I had a heck of a time on linux setting up rc init scripts, due to 
> something similar to this. My discovery (and unlikely this works on 
> windows) was that in the bin/ directory the shell scripts search for 
> setenv.sh, which by default doesn't exist. By bin/setenv.sh 
> for tomcat 
> 5.0.30 it suddenly worked, whereas manually adding JAVA_HOME and 
> CATALINA_HOME to individual startup files always left 
> something broken. 
> Here is what I added, see if an adjusted version of this works:
> 
> #!/bin/sh
> 
> export JAVA_HOME="/opt/jdk1.5.0"
> export CATALINA_HOME="/usr/local/jakarta-tomcat-5.0.30"
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message