tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arnab Chakravarty" <achakrava...@sapient.com>
Subject RE: UTF-8 Encoding in Jsp
Date Wed, 01 Dec 2004 10:37:59 GMT
Hi,

Thanks for the reply but it did not work. May be I didn't explain the
problem correctly.

I am running an application that supports all the languages but only in
some specific places of the application and I have made those places
UTF-8 complaint.

Further, they are being saved to Database (Oracle 9). When we are
reading the data back from the database, junk characters are displayed
on the screen. Yes, the database is set to support UTF-8 Encoding and
this is working with the old version of tomcat 3.3 and not with current
upgraded version of tomcat 5.0

There are also places in the application where drop downs contain some
different language support and we can see those charsets (Japanese,
Chinese etc) appearing. Only, when I try to display on the screen
through the jsp file, I am encountering this problem of junk characters
begin displayed.

Hope I have set more context around the problem. Please help me resolve
this issue.

Thanks,
Arnab

-----Original Message-----
From: Mariano [mailto:mlopez@sescam.org] 
Sent: Wednesday, December 01, 2004 12:54 PM
To: 'Tomcat Users List'
Subject: RE: UTF-8 Encoding in Jsp

You should use too:

<head>
	<META http-equiv="Content-Type" content="text/html;
charset=UTF-8">
</head>

and this scriptlet:

	request.setCharacterEncoding("UTF-8");

at the beginning.

I hope this help you

-----Mensaje original-----
De: Arnab Chakravarty [mailto:achakravarty@sapient.com]
Enviado el: martes, 30 de noviembre de 2004 15:28
Para: Tomcat Users List
Asunto: UTF-8 Encoding in Jsp


Hi all,

I need to make my all jsp files compatible with UTF-8 Encoding and even
though I am using the directives:

<%@ page pageEncoding="UTF-8"%>
<%@ page contentType = "text/html;charset=UTF-8"%>

in the jsp files, cannot make it work.

Using tomcat version 5. Is there any config changes I need to make for
the UTF-8 Encoding to work.

Please help.

Thanks in advance,
Arnab

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message