tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: 5.5.4 problems deploying with context descriptors
Date Sat, 04 Dec 2004 23:36:24 GMT
the point is, you ask a basic question, you get a basic answer. i could have answered this
in 1 reply if you had provided your config files. it could have been path, it could have been
that you were not using the new Resource element, it could have been that you had not placed
a ROOT.xml file (uppercase required) in your catalina.home/conf/Catalina/localhost folder
and it could have been that you did not rename your webapp to ROOT (deleting the default Tomcat
intro page which is ROOT by default).
 
that is why you got your basic answer and that is why I asked for more information, like you
will note I gave in my posts.
 
i will admit this however, the 5.5 Context configuration documentation does not mention anything
about the new ROOT configuration and that path="" will no longer be sufficient to provide
the default root context, so my apologies for that, I thought it did. 
 
glad you sorted it. Allistair.
 
 

	-----Original Message----- 
	From: hanasaki [mailto:hanasaki@hanaden.com] 
	Sent: Sat 04/12/2004 23:28 
	To: Tomcat Users List 
	Cc: 
	Subject: Re: 5.5.4 problems deploying with context descriptors
	
	

	Well... I found what looks like an old post from Allistair with the same
	problem.  I am glad someone helped him out with the answer!  The "path"
	element has been taken out of the context snipet and the xml file for
	the root/default context hs been renamed root.xml but tomcat is still
	serving up the default tomcat index page.  There are no errors in the
	log files and nothing indicating the root.xml was even looked at for the
	virtual host.
	
	http://www.mail-archive.com/tomcat-user@jakarta.apache.org/msg140750.html
	
	Allistair Crossley wrote:
	> Hi
	> 
	> how about you explain a bit more about your problem
	> 
	>
	>>Is this a known problem?  Has the config process changed?
	>
	> 
	> yes it has.
	> 
	> now it's your job to explain what is happening, including relevant error logging, behaviour,
configuration files etc... start with your context's XML file ... post a little so we can
see.
	> 
	> Allistair.
	>
	>       -----Original Message-----
	>       From: hanasaki [mailto:hanasaki@hanaden.com]
	>       Sent: Sat 04/12/2004 22:30
	>       To: Tomcat Users List
	>       Cc:
	>       Subject: Re: 5.5.4 problems deploying with context descriptors
	>      
	>      
	>
	>       http://jakarta.apache.org/tomcat/tomcat-5.5-doc/config/host.html#Automatic%20Application%20Deployment
	>       http://jakarta.apache.org/tomcat/tomcat-5.0-doc/config/host.html#Automatic%20Application%20Deployment
	>      
	>       both of the above pages are the same for auto deployment.  What do you
	>       mean "yes".  Please explain a bit more.
	>      
	>       Allistair Crossley wrote:
	>       > yes for Context and Resource (e.g JDBC Datasource) configuration. read the
tomcat configuration documentation online.
	>       >
	>       >       -----Original Message-----
	>       >       From: hanasaki [mailto:hanasaki@hanaden.com]
	>       >       Sent: Sat 04/12/2004 22:11
	>       >       To: LIST - Tomcat Users
	>       >       Cc:
	>       >       Subject: 5.5.4 problems deploying with context descriptors
	>       >     
	>       >     
	>       >
	>       >       Just pulled down 5.5.4 to upgrade from 5.0.28
	>       >     
	>       >       The xml descriptors and hostname directories have been copied from
	>       >       5.0.28 to 5.5.4 but the contexts do not appear to be deployed.
	>       >       Everything ran fine on 5.0.28
	>       >     
	>       >       ie: under..../Catalina/myhost/descriptor1.xml
	>       >     
	>       >       Is this a known problem?  Has the config process changed?
	>       >     
	>       >       OS = Linux
	>       >       jdk = 5.0
	>       >     
	>       >       ---------------------------------------------------------------------
	>       >       To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
	>       >       For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
	>       >     
	>       >     
	>       >
	>       >
	>       >
	>       > <FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE>
	>       > -------------------------------------------------------
	>       > QAS Ltd.
	>       > Developers of QuickAddress Software
	>       > <a href="http://www.qas.com">www.qas.com</a>
	>       > Registered in England: No 2582055
	>       > Registered in Australia: No 082 851 474
	>       > -------------------------------------------------------
	>       > </FONT>
	>       >
	>      
	>       ---------------------------------------------------------------------
	>       To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
	>       For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
	>      
	>      
	>
	
	---------------------------------------------------------------------
	To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
	For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
	
	

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message