tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Rossbach ...@objektpark.de>
Subject Re: Does Tomcat 5.5 support jikes?
Date Fri, 03 Dec 2004 10:23:42 GMT
Hey,

you can configure the Ant Compiler with following steps:

Copy   ant.jar and ant-launcher.jar at common/lib

Edit conf/web.xml or your own app web.xml ( Change servlet-name at 
definition and mappings!)
    <servlet>
        <servlet-name>jsp</servlet-name>
        <servlet-class>org.apache.jasper.servlet.JspServlet</servlet-class>
        <init-param>
            <param-name>compiler</param-name>
            <param-value>modern</param-value>
        </init-param>
        <init-param>
            <param-name>fork</param-name>
            <param-value>false</param-value>
        </init-param>
        <init-param>
            <param-name>xpoweredBy</param-name>
            <param-value>false</param-value>
        </init-param>
        <load-on-startup>3</load-on-startup>
    </servlet>

I also thing  that ant jikes mode work with Tomcat 5.5.x and mixed 
operating with Ant and JDT is
possible.

regards
Peter



Bill Barker schrieb:

>"Kevin A. Burton" <burton@newsmonster.org> wrote in message 
>news:41AFB035.4070107@newsmonster.org...
>  
>
>>Kevin A. Burton wrote:
>>
>>    
>>
>>>This isn't fun:
>>>
>>>      
>>>
>>>>       -->
>>>>  <!-- If you wish to use Jikes to compile JSP 
>>>>       -->
>>>>  <!--   Set the init parameter "compiler" to "jikes". 
>>>>        -->
>>>>  <!--   the property "-Dbuild.compiler.emacs=true" when starting 
>>>>cat    -->
>>>>  <!--   by adding the above to your CATALINA_OPTS environment 
>>>>iable.    -->
>>>>  <!--   If you get an error reporting that jikes can't use UTF8 
>>>>encoding,  -->
>>>>  <!--   try setting the init parameter "javaEncoding" to 
>>>>-8859-1".     -->
>>>>        
>>>>
>>>
>>>But I follow these instructions (as I did with Tomcat 5.0) and Tomcat 5.5 
>>>STILL uses jdtool!
>>>
>>>Any thoughts?
>>>
>>>      
>>>
>>It looks like the web.xml configuration is lying about a number of things. 
>>Tomcat 5.5 ONLY used the JDTCompiler and will never use the AntCompiler. 
>>Theres not even a way to tell it to use one or the other.
>>
>>    
>>
>
>The only way (currently) to use the AntCompiler is to remove the 
>jasper-compiler-jdt.jar and install ant.jar and ant-launcher.jar instead.
>
>  
>
>>Thus fork, jikes, etc don't matter anymore.
>>
>>Kevin
>>
>>-- 
>>
>>Use Rojo (RSS/Atom aggregator).  Visit http://rojo.com. Ask me for an 
>>invite!  Also see irc.freenode.net #rojo if you want to chat.
>>
>>Rojo is Hiring! - http://www.rojonetworks.com/JobsAtRojo.html
>>
>>If you're interested in RSS, Weblogs, Social Networking, etc... then you 
>>should work for Rojo!  If you recommend someone and we hire them you'll 
>>get a free iPod!
>>   Kevin A. Burton, Location - San Francisco, CA
>>      AIM/YIM - sfburtonator,  Web - http://peerfear.org/
>>GPG fingerprint: 5FB2 F3E2 760E 70A8 6174 D393 E84D 8D04 99F1 4412 
>>    
>>
>
>
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message