tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeff Hoffmann <j...@propertykey.com>
Subject Re: class file has wrong version?
Date Wed, 01 Dec 2004 17:20:24 GMT
Chris Cherrett wrote:
> I am trying to deploy with a client and am getting an error that I have never 
> seen before. Any ideas where to start?
> 
> bad class 
> file: /usr/local/tomcat/webapps/tsiware/WEB-INF/classes/ConnectionPool/ConnectionPool.class
> class file has wrong version 49.0, should be 48.0
> Please remove or make sure it appears in the correct subdirectory of the 
> classpath.
> ConnectionPool dbConnectionPool = ConnectionPool.getInstance();

The class was compiled with 1.5 & you're trying to run it on a 1.4 JVM. 
  Recompile the class on 1.4 or upgrade the JVM.

-- 
Jeff Hoffmann
jeff@propertykey.com

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message