tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Chan <>
Subject Strange Problem on SSL with tomcat
Date Wed, 22 Dec 2004 03:38:44 GMT
Hi all,

I have a strange problem when I configure the tomcat running SSL.

I have created the keystore file in / following the steps in
documentation. And also uncomment the tag inside server.xml. I tried
to start the tomcat, the SSL work fine in my old tomcat 4.1.18. But it
cannot work in tomcat 4.1.31 and 5.0.28 with the same keystore file
since I wanna upgrade my tomcat version. I dont know what cause this
problem. Pls help me THX

When I analysis the catalina.out file, I found when the SSL cannot
work, the below message showed:- Keystore was tampered with, or password was incorrect
       at org.apache.coyote.http11.Http11Protocol.init(
       at org.apache.coyote.tomcat4.CoyoteConnector.initialize(
       at org.apache.catalina.core.StandardService.initialize(
       at org.apache.catalina.core.StandardServer.initialize(
       at org.apache.catalina.startup.Catalina.start(
       at org.apache.catalina.startup.Catalina.execute(
       at org.apache.catalina.startup.Catalina.process(
       at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
       at sun.reflect.NativeMethodAccessorImpl.invoke(
       at sun.reflect.DelegatingMethodAccessorImpl.invoke(
       at java.lang.reflect.Method.invoke(
       at org.apache.catalina.startup.Bootstrap.main(

Ben Chan

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message