tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bric...@brick.net
Subject Issue with J2SSE on Solaris and AIX
Date Tue, 28 Dec 2004 17:45:32 GMT
I am working on migrating approx 10 applications from Tomcat 4.0.6 on
Solaris to Tomcat 4.0.6 on AIX. I am running into an issue related to
having Java Security turned on. On the Solaris catalina.policy, I was
getting the following security exception:

Security Violation, attempt to use Restricted Class:
org.apache.catalina.util.ParameterMap
java.security.AccessControlException: access denied
(java.lang.RuntimePermission
accessClassInPackage.org.apache.catalina.util)

I tracked down the class to a jar in the $CATALINA_HOME/server directory,
so I added the following perm to the catalina.policy:

grant codeBase "file:${catalina.home}/server/-" {
        permission java.lang.RuntimePermission
"accessClassInPackage.org.apache.catalina.util.ParameterMap";
};

That fixed the problem. On Solaris. When I move the same config to AIX, I
keep getting the exception thrown above, yet I cannot get the grant
staement above to get rid of it on AIX.

Any ideas here? Is this a bug of some sort?

Ben Ricker


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message