tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From sven morales <aka_ser...@yahoo.com>
Subject Re: standard.jar broke in Tomcat?
Date Thu, 16 Dec 2004 04:49:09 GMT
  Why it could not find it?  Where is it in your
standard.jar?  I do not believe the Digester looks at 
META-INF/  and checked for contents like these c.tld
in that directory.  Off hand I do not remember what
functionality META-INF/ is for other than this is
where you have a MANIFEST.MF file, the index file for
the jars your webapp uses, and  stash your context.xml
file.
Maybe listing it in MANIFEST.MF makes it "available" ?


--- Tim Watts <timtw@earthlink.net> wrote:

> I pulled c.tld from the jar, put it in WEB-INF and
> pointed 
> <taglib-location> there. That fixed it. Thank you
> very much.
> 
> But what still puzzles me is why TomCat couldn't
> find it in the jar? Is 
> there a special syntax for referencing .tlds in a
> jar? Anyway, thanks 
> again for your help.
> 
> sven morales wrote:
> 
> > Thats now how its defined on mine. The
> > <taglib-location> on mine points to a tld file and
> not
> > the standard.jar.  The TLD files should be like
> > definition and attributes of those tags, unless
> your
> > standard.jar includes them already.  My
> standard.jar
> > are basically the package of classes.  An excerpt
> of
> > the "out" tag from the c.tld:
> > 
> > 82   <tag>
> >      83     <name>out</name>
> >      84    
> >
>
<tag-class>org.apache.taglibs.standard.tag.el.core.OutTag</tag-class>
> >      85     <body-content>JSP</body-content>
> >      86     <description>
> >      87     Like &lt;%= ... &gt;, but for
> expressions.
> >      88     </description>
> >      89     <attribute>
> >      90         <name>value</name>
> >      91         <required>true</required>
> >      92         <rtexprvalue>false</rtexprvalue>
> >      93     </attribute>
> >      94     <attribute>
> >      95         <name>default</name>
> >      96         <required>false</required>
> >      97         <rtexprvalue>false</rtexprvalue>
> >      98     </attribute>
> >      99     <attribute>
> >     100         <name>escapeXml</name>
> >     101         <required>false</required>
> >     102         <rtexprvalue>false</rtexprvalue>
> >     103     </attribute>
> >     104   </tag>
> > 
> > 
> > 
> > 
> > --- Tim Watts <timtw@earthlink.net> wrote:
> > 
> > 
> >>Here you go:
> >>
> >><taglib>
> >>
> >>
> >
>
<taglib-uri>http://java.sun.com/jstl/core</taglib-uri>
> > 
> >>
> >
>
<taglib-location>/WEB-INF/lib/standard.jar</taglib-location>
> > 
> >></taglib>
> >>
> >>The jar is in that location. And your assumption
> is
> >>correct. I'm using 
> >>v1.0 of the JSTL downloaded from Apache.
> >>
> >>sven morales wrote:
> >>
> >>
> >>>Hi,
> >>>   Can you paste the relevant section of your
> >>>deployment descriptor web.xml for your demo
> >>
> >>webapp?
> >>
> >>>Specifically, the 
> >>><taglib>
> >>>  
> >>>
> >>
> >
>
<taglib-uri>http://java.sun.com/jstl/core</taglib-uri>
> > 
> >>>   <taglib-location>....
> >>> 
> >>>Am assuming this is JSP 1.2?
> >>>
> >>>aka_sergio
> >>>   
> >>>
> >>>--- Tim Watts <timtw@earthlink.net> wrote
> >>>
> >>>
> >>>>Hi,
> >>>>
> >>>>I'm having problems using standard.jar. For a
> >>
> >>simple
> >>
> >>>>page such as this:
> >>>>
> >>>><?xml version="1.0" encoding="ISO-8859-1" ?>
> >>>><!DOCTYPE html PUBLIC "-//W3C//DTD XHTML
> 1.1//EN" 
> >>>>"http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd">
> >>>><html xmlns="http://www.w3.org/1999/xhtml">
> >>>><head>
> >>>><%@ taglib uri="http://java.sun.com/jstl/core"
> >>>>prefix="c" %>
> >>>></head>
> >>>><body>
> >>>><p>Remote user: <c:out
> >>>>value="${request.remoteUser}"/></p>
> >>>></body>
> >>>></html>
> >>>>
> >>>>Tomcat 4.1.31 complains that it doesn't know
> what
> >>>>c:out is with this 
> >>>>exception:
> >>>>
> >>>>org.apache.jasper.JasperException:
> >>>>/demo/userinfo-tc.jsp(7,16) No such 
> >>>>tag out in the tag library imported with prefix
> c
> >>>>
> >>>>Tomcat 5.0.28 under JBoss 3.2.6 gives a little
> >>>>clearer explanation:
> >>>>
> >>>>org.apache.jasper.JasperException: Unable to
> read
> >>>>TLD 
> >>>>"META-INF/taglib.tld" from JAR file 
> >>>>
> >>>
> >>>
> >
>
"file:/C:/jboss-3.2.6/server/default/tmp/deploy/tmp12024SpeEA.ear-contents/spe.war/WEB-INF/lib/standard.jar":
> > 
> >>>>java.lang.NullPointerException
> >>>>
> >>>>It appears to be looking for taglib.tld for some
> >>>>reason. It, in fact, 
> >>>>does not exist in the jar. But why is it looking
> >>
> >>for
> >>
> >>>>this?
> >>>>
> >>>>The page works fine in WebSphere Studio 5.1.
> >>>>
> >>>>Has anyone else encountered this? How did you
> work
> >>>>around it? Am I doing 
> >>>>something wrong? Any insight/experience will be
> >>>>greatly appreciated.
> >>>>
> >>>>Thanks.
> >>>>
> >>>>
> >>>>
> >>>
> >>>
> >
>
---------------------------------------------------------------------
> > 
> >>>>To unsubscribe, e-mail:
> >>>>tomcat-user-unsubscribe@jakarta.apache.org
> >>>>For additional commands, e-mail:
> >>>>tomcat-user-help@jakarta.apache.org
> >>>>
> >>>>
> >>>
> >>>
> >>>
> >>>
> >>>		
> >>>__________________________________ 
> >>>Do you Yahoo!? 
> >>>Jazz up your holiday email with celebrity
> designs.
> >>
> >>Learn more. 
> >>
> >>>http://celebrity.mail.yahoo.com
> >>>
> >>>
> >>
> >
>
---------------------------------------------------------------------
> 
=== message truncated ===


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message