tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Barker" <wbar...@wilshire.com>
Subject Re: Tomcat 5.0.28 fails to start
Date Sun, 07 Nov 2004 22:10:34 GMT
It is required for all Tomcat 5.x unless you are using a 1.5 JVM (which 
ships with the javax.management.* classes).  Hence the message below if 
Tomcat can't find a JMX implementation.

"sven morales" <aka_sergio@yahoo.com> wrote in message 
news:20041107195549.10874.qmail@web54409.mail.yahoo.com...
>  Am curious, this jmx.jar is required in all Tomcat
> 5.x?  I thought it was only for the jmxproxy servlet
> under the manager webapp?
>
>
> --- Bill Barker <wbarker@wilshire.com> wrote:
>
>> The problem is that Tomcat isn't finding the classes
>> in
>> $CATALINA_HOME/bin/jmx.jar.  Either this jar got
>> corrupted somehow, or your
>> JVM isn't honoring the classpath in the manifest.
>> If the jar is there and
>> looks ok, then try adding it to the classpath in the
>> startup script.
>>
>> "Steve Delahunty" <steved@e12host.com> wrote in
>> message
>> news:1099743726.19119.25.camel@e12host.com...
>> >I recently downloaded a binary version of tomcat
>> version 5.0.28. I
>> > configured it and everything was running fine.
>> Then, a few days ago,
>> > when I try to start it (using bin/startup.sh), I
>> get the following
>> > message in logs/catalina.out:
>> >
>> >
>>
> ---------------------------------------------------------------
>> > Due to new licensing guidelines mandated by the
>> Apache Software
>> > Foundation Board of Directors, a JMX
>> implementation can no longer
>> > be distributed with the Apache Tomcat binaries. As
>> a result, you
>> > must download a JMX 1.2 implementation (such as
>> the Sun Reference
>> > Implementation) and copy the JAR containing the
>> API and
>> > implementation of the JMX specification to:
>> > ${catalina.home}/bin/jmx.jar
>> >
>>
> ----------------------------------------------------------------
>> >
>> > Tomcat exits after logging this message. I
>> searched the web for
>> > information regarding this issue and I did see
>> someone else posting a
>> > similar question, but there was no response. I
>> downloaded and tried
>> > running version 5.0.29, but the same thing is
>> happening. I searched
>> > through the archive, but I don't see any
>> information regarding this
>> > issue.
>> >
>> > I have this sinking feeling that the answer is
>> obvious, or the answer is
>> > posted in place that I have not searched yet.
>> Thanks in advance.
>> >
>> > I'm running SUSE Linux 9.0 with an unmodified
>> 2.4.21 kernel.
>>
>>
>>
>>
>>
> ---------------------------------------------------------------------
>> To unsubscribe, e-mail:
>> tomcat-user-unsubscribe@jakarta.apache.org
>> For additional commands, e-mail:
>> tomcat-user-help@jakarta.apache.org
>>
>>
>
>
>
>
> __________________________________
> Do you Yahoo!?
> Check out the new Yahoo! Front Page.
> www.yahoo.com 




---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message