tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From O.Stro...@erlenbach.de
Subject Starting Tomcat as an Apache inprocess with Jni
Date Mon, 08 Nov 2004 07:40:13 GMT
Hi,

I have problems starting the Tomcat as an inprocess of Apache via Jni. 
I tried that with the examples of the Jakarta Hompage.
Running Apache and Tomcat seperatly and connect both with a 
Socket-Connection is no problem and works fine. 
That tells me that the mod_jk2 is well working.

My System :
Windows XP SP1
Apache 2.0.52 (Folder: C:\Programme\Apache Group\Apache2)
Tomcat 5.0.28 (Folder: C:\Programme\Apache Group\Tomcat5)
Java SDK 1.5  (Folder: C:\Programme\Java\jdk1.5.0)


Error file of Apache (Folder: C:\Programme\Apache Group\Apache2\logs):

[Thu Nov 04 08:08:52 2004] [notice] Parent: Created child process 4628
[Thu Nov 04 08:08:52 2004] [notice] Child 4628: Child process is running
[Thu Nov 04 08:08:52 2004] [error] workerEnv.initChannel() init failed for 
channel.jni:jni
[Thu Nov 04 08:08:52 2004] [error] workerEnv.initWorkers() init failed for 
worker.jni:onStartup
[Thu Nov 04 08:08:52 2004] [error] workerEnv.initWorkers() init failed for 
worker.jni:onShutdown
[Thu Nov 04 08:08:52 2004] [notice] Child 4628: Acquired the start mutex.
[Thu Nov 04 08:08:52 2004] [notice] Child 4628: Starting 250 worker 
threads.

it seems that the Apache can't find the starter class for the Tomcat.
What have I done wrong?


As I know, running Tomcat as an inprocess of Apache on the same PC is the 
fastest connection between both servers.
Because of that i tried that very hard getting this constellation running.


best regards

Oliver
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message