tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Phillip Qin <Phillip....@shareowner.com>
Subject RE: Problem displaying PDF in IE6 from Tomcat using the ActiveX R eader Plug-in
Date Mon, 15 Nov 2004 19:04:17 GMT
There are security and privacy settings in IE affect PDF generation. BTW,
ensurethe link before query string ends with .pdf

-----Original Message-----
From: Aman Raheja [mailto:araheja@techquotes.com] 
Sent: November 15, 2004 1:40 PM
To: tomcat-user@jakarta.apache.org
Subject: Problem displaying PDF in IE6 from Tomcat using the ActiveX Reader
Plug-in


Problem: 

When we try to display a dynamically generated PDF file, IE launches the 
Adobe Acrobat Reader Plugin, but then just a blank page is displayed and 
the IE status says "Done".  No error message is displayed.  No error is 
generated in the System Event logs.

The issue seems to be that every request to request to Tomcat for the 
PDF send back the request with "charset=ISO-8859-1" in the 
"Content-type" Header. We want to figure out a way to verify that this 
is the issue. One way might be to somehow get Tomcat to not append the 
Character Set in the header. Is there a way to do this?

Environment:

- Client: Windows XP or Windows 2000
- Server: Tomcat 4.0.6/JDK 1.3.1 running on Solaris and Windows XP 
(problem exists on both)
- Adobe Reader 6.0.1 (occurs with 6.0.2 patch as well)
- IE 6.0.2800


Additional Information:

1) Our URLs are formed like this: 

http://app.ourserver.com/appname/docViewAGN.jsp?RepoType=C&ID=18698&DocName=
Germany&entry=&DocType=pdf&category=Research

2) Our app is issuing GETs, not POSTs.

3) This is happening on multiple PCs.  One thing we noticed is this may 
be somewhat Reader version dependent -- we have a few machines left with 
Reader 5 installed, and they do not seem to have the problem.

4) When the problem occurs, if you then launch Reader manually, the 
document that didn't display in the IE window is automatically displayed 
in the full client Reader app.!!!

5) If we set Reader to not open up PDFs in browser windows, the Reader 
window launches and opens the PDF file just fine.   [This is a client 
solution, and not practical to implement across hundreds of PCs 
unfortunately.]

6) We actually have one PC with Windows XP, Reader 6.0.1, and IE 6.0.2 
that works.  Could this problem be caused by some specific Windows or IE 
patch?

7) We've scoured the forums and tried several things including setting 
all security levels to Low in IE, adding a dummy parm at the end of the 
URL to fool IE into launching the PDF correctly (e.g. &dummy=file.pdf), 
and various header settings to force caching on to 30 seconds, etc.  
None of this had any effect.

8) Also, we saw some references to problems caused by Tomcat 4.0.6 
adding "charset=ISO-8859-1" to the Content-Type header in the response.  
How can we override this to see if that's the problem?

Thanks
Aman Raheja


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


!DSPAM:4198f83938781679484274!

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message