tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gibson, Danny" <danny.gib...@cingular.com>
Subject RE: mod_jk.so for HP-UX 11.11
Date Mon, 29 Nov 2004 19:04:15 GMT
Hi Ya( Dale/Wendy),

Yes I am using the GNU tools.  I also have my PATH set to call
/usr/local/bin first where all the GNU tools reside.  I also created a
JK_DIR environment setting prior to running the configure script.  Configure
seems to run fine, as does the common Makefile.  It just dies at the
apache13 Makefile.  I also tried using the mod-jk.so which resides under the
/opt/hpws/tomcat/jk/apache2 but it must not be a correct version to be
loaded under apache1.3.33 as I get /usr/lib/dld.sl: Unresolved symbol:
errors when Apache tries to load it.  It appears that the hpws is Apache 2
which was loaded during the build, but I am not using it as I have multiple
v-tiers which need their own separate Apache installs.

When I run the configure script I am using the following command:

./configure --with-apxs=/opt/app/darw1/apache1.3.33/bin/apxs

I have JAVA_HOME set as well.

I compiled Apache 1.3.33 from source with no compiler or make issues.  It's
just this JK connector build I am having extreme trouble with...

I may have to remove the Apache 2 and try installing an HP-UX depot of
Apache 1.3 in hopes I can get the mod_jk.so library file.

I was just hoping someone already had it compiled to save me the time of
removing the Apache 2 and installing the Apache 1.3

Anyway, I am open to any suggestions.

Danny


-----Original Message-----
From: Dale, Matt [mailto:Matt.Dale@beCogent.com] 
Sent: Monday, November 29, 2004 12:47 PM
To: Tomcat Users List
Subject: RE: mod_jk.so for HP-UX 11.11

have you got the Gnu versions of all the tools, ie gcc, make etc?
-----Original Message-----
From: Gibson, Danny [mailto:danny.gibson@cingular.com]
Sent: 29 November 2004 18:01
To: 'tomcat-user@jakarta.apache.org'
Subject: mod_jk.so for HP-UX 11.11
Hello All,
Can someone put me out of my misery?  I have attempted to build the
mod_jk.so for Apache 1.3.33 on HP-UX 11.11 multiple times and failing
miserable.  I have tried with multiple versions of the src but they ALL
continue to fail on line 22 of the apache13/Makefile referencing the
following during the make: 
# make
No suffix list.
Making all in common --- This runs but errors after performing the make to
the apache-1.3 Makefile Making all in apache-1.3
Make: line 22: syntax error.  Stop.
*** Error exit code 1
Line 21 -  JK_DIR := ..
Line 22 -  BUILD_DIR = ${JK_DIR}/../build/jk/apache13 I have tried
everything I can think of to get it to work but alas, I am obviously not
smart enough to figure it out.
Does someone have it already built that I could sponge off of in an attempt
to get it working for I retire?
Thanks In Advance,
Danny

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message