tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: org.apache.catalina.connector.Request
Date Tue, 30 Nov 2004 15:29:26 GMT

Hi,
Much of the Tomcat 4.x code is in the CVS module jakarta-tomcat-4.0.
The jakarta-tomcat-catalina, jakarta-tomcat-jasper, etc were separated
out for Tomcat 5.0.

It's kind of interesting how you've chosen to spend all this time doing
development work on an old branch.

Yoav Shapira http://www.yoavshapira.com
 

>-----Original Message-----
>From: Anderson, M. Paul [mailto:Paul.Anderson@jhuapl.edu]
>Sent: Tuesday, November 30, 2004 10:17 AM
>To: Tomcat Users List
>Subject: RE: org.apache.catalina.connector.Request
>
>I am creating a custom realm because I want to take advantage of
>Tomcat's implementation to prevent users from accessing some
>directories.  The only real addition I'm adding to the realm is storing
>passwords using a salted hashing scheme so I'm only overriding the
>authenticate method although I'd like access to the request object to
>redirect when necessary.
>
>In the CVS browser I only saw revisions relating to Tomcat 5 - it
wasn't
>obvious to me which version was for Tomcat 4.1.
>
>-----Original Message-----
>From: Tim Funk [mailto:funkman@joedog.org]
>Sent: Tuesday, November 30, 2004 7:02 AM
>To: Tomcat Users List
>Subject: Re: org.apache.catalina.connector.Request
>
>
>In the cvs browser, you can view by a specific tag. From there you can
>easily
>determine which revision is associated with which version.
>
>Next - it will probably be much easier to not use container based
>authentication based on your requirements. Servlet Filters would
>probably be
>much easier.
>
>As for the java imports, importing a class and importing a source file
>are 2
>totally different actions.
>
>-Tim
>
>
>Anderson, M. Paul wrote:
>
>> Sorry for another question...I am using Tomcat 4.1 ... Is there a way
>> to know which version of the org.apache.catalina.connector.Request
>> class is used with this version?  I have gone to the Apache CVS
>> Repository but I can't figure out which version revision of
>> JDBCRealm.java goes with this Tomcat version.  I guess in the mean
>> time I'll try to find the source for Tomcat 4.1 but I don't suspect
>> its available any longer.
>>
>> I'm trying to create a derived realm and I want to re-direct the user
>> to an error page after he/she has tried to access the site 3 times
>> unsuccessfully.  To do this I need access to a Response object but I
>> can't seem to get at this very easily.
>>
>> I find it odd that in Java the imports in a base class do not carry
>> over into a derived class...this is not like c++ as I am use to.
>>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message