tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Remy Maucherat <>
Subject Re: Auto-deploy not working in Tomcat 5.5.4 when .war file has a META-INF/context.xml?
Date Thu, 11 Nov 2004 19:17:39 GMT
On Thu, 11 Nov 2004 11:09:58 -0600, Jonathan Eric Miller
<> wrote:
> I don't see it at least on the inital bug report page at
> Maybe I need to commit the page first and there's another page...
> I don't want to submit a report just yet, because I'm still in the process
> of trying to figure out how the new logging works and I want to make sure
> there isn't a error occurring that I'm not seeing because of this.
> I tried it with Tomcat 5.0.28 and found that it was throwing an exception in
> the console about the context path not being set. So, I added that path to
> my context.xml and it then worked with 5.0.28, but, still won't work with
> 5.5.4, but, like I said, I want to see if I can figure out how to use the
> new logging. My guess is that it's something similar and I'm just not seeing
> the error message.

Don't use path or docBase (unless the webapp is not inside the host
appBase) in your context.xml file with Tomcat 5.5.

I tested it, and it works fine for me, so please don't open a bug report.

- start Tomcat
- put test-with-context.war in webapps
- it gets autodeployed
- use a zip tool to modify the war (I added an additional resource in it)
- it gets redeployed (the expanded folder is deleted, and then
recreated by expanding the war again)

Rémy Maucherat
Developer & Consultant
JBoss Group (Europe) SàRL

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message