tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Allistair Crossley" <Allistair.Cross...@QAS.com>
Subject RE: Tomcat 5.5.4 / Context not responding - Test example webapp
Date Fri, 12 Nov 2004 12:10:09 GMT
To demonstrate this problem, I have reduced it to a small web app.

1. Install 5.5.4 and delete tomcat/webapps/ROOT
2. Create file test.xml and save it to tomcat/conf/Catalina/localhost with the content

<Context path="" docBase="/test"></Context>

3. Create folder tomcat/webapps/test
4. Create in that folder (3) file called test.jsp with content

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
<title>Hello 5.5.4</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
</head>

<body>
	<%= "Hello 5.5.4" %>
</body>
</html>

5. Start tomcat
6. Request http://yourserver:8080/test/test.jsp

You should get a blank page. Not good!

Cheers, Allistair.

> -----Original Message-----
> From: Allistair Crossley 
> Sent: 12 November 2004 11:33
> To: tomcat-user@jakarta.apache.org
> Subject: Tomcat 5.5.4 / Context not responding
> 
> 
> Hi All,
> 
> Well, I finally have Tomcat 5.5.4 running my application with 
> NTLM authentication and logging. One final hurdle remains and 
> that is requests and the web application context.
> 
> It appears that if I make a request to my web application with
> 
> http://testserver/loadPage.do
> 
> it does not work. When I say does not work, I mean I get a 
> blank page back.
> 
> When I request
> 
> http://testserver/iq/loadPage.do
> 
> i.e adding the context name, it works.
> 
> I am assuming this is configuration. I have iq.xml located in 
> tomcat/conf/Catalina/localhost. The entry looks like this...
> 
> <Context path="" docBase="/iq" reloadable="true">
> 
> 	<Resource name="jdbc/iq" auth="Container"
> 		type="javax.sql.DataSource" 
> 		username="usr" password="pw"
> 		
> driverClassName="net.sourceforge.jtds.jdbc.Driver" 
> url="jdbc:jtds:sqlserver://testserver:1433/db_iQ;charset=Cp125
> 2;TDS=7.0"
> 		maxActive="8" maxIdle="4" maxWait="10000" 
> validationQuery="SELECT 1 + 1" />
> </Context>
> 
> This is how 5.0.28 used to be setup in terms of path="" and 
> docBase="/iq". I looked at the 5.5 docs but path and docBase 
> appear to be used in the same way.
> 
> I have also deleted ROOT from webapps.
> 
> Can anyone suggest why I am having to add my web application 
> name into URLs?
> 
> Cheers!
> 
> 
> 
> <FONT SIZE=1 FACE="VERDANA,ARIAL" COLOR=BLUE> 
> -------------------------------------------------------
> QAS Ltd.
> Developers of QuickAddress Software
> <a href="http://www.qas.com">www.qas.com</a>
> Registered in England: No 2582055
> Registered in Australia: No 082 851 474
> -------------------------------------------------------
> </FONT>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message