tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scott Mueller" <sc...@acceleratebiz.com>
Subject RE: problem accessing datasource in 5.5.4 application
Date Tue, 16 Nov 2004 18:27:15 GMT
Hi Remy,

Yes, what you said worked thanks!  I had a ResourceLink previously, but I
ALSO had a Resource element without the attributes in my context.xml file.
That didn't work, so I removed both Resource* elements from my context.xml.
That didn't work either.  Removing JUST the Resource element worked:

  <Resource auth="Container" description="IspManager database"
name="data/ispmanagerpg" type="javax.sql.DataSource"/>
  <ResourceLink global="data/ispmanagerpg" name="data/ispmanagerpg"
type="javax.sql.DataSource"/>
</Context>  

That worked fine in 5.0.x.  Not in 5.5.4, so I removed the 2 Resource*
elements and it still didn't work.  What finally worked was ONLY removing
the Resource element.

-----Original Message-----
From: Remy Maucherat [mailto:remy.maucherat@gmail.com] 
Sent: Tuesday, November 16, 2004 6:06 AM
To: Tomcat Users List
Subject: Re: problem accessing datasource in 5.5.4 application

On Tue, 16 Nov 2004 02:54:23 -0500, Scott Mueller
<scott@acceleratebiz.com> wrote:
> Someone please help me.  The same code that was working fine in tomcat
> 5.0.19 does not work anymore in 5.5.4 for accessing the database.

I don't see how it could have worked without a ResourceLink element
for your context. You can define the ResourceLink globally in
conf/context.xml if all your contexts will need it.

-- 
xxxxxxxxxxxxxxxxxxxxxxxxx
Rémy Maucherat
Developer & Consultant
JBoss Group (Europe) SàRL
xxxxxxxxxxxxxxxxxxxxxxxxx

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message