tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mark Claassen <...@donnell.com>
Subject CGI ...yeah, I know (Tomcat 4.1.29)
Date Fri, 05 Nov 2004 22:07:18 GMT
I know that Tomcat is not an ideal CGI server, but I am having real trouble
getting it to work at all.  Most often I get the Exception below, and it
doesn't seem to be running our perl program at all.  (We can run the perl
program by hand though).  We had a bit of trouble getting it setup in the
first place, and we got errors way different from this.  I figured that
since we were getting this, we must have everything else setup correctly.

Looking at the 4.1.27 source this is:
1686:     commandsStdIn.flush();
          commandsStdIn.close();
commandsStdIn is the output stream to the process.

Anyone have any ideas on where to start looking?

Thanks,
Mark

java.io.IOException: Broken pipe
        at java.io.FileOutputStream.writeBytes(Native Method)
        at java.io.FileOutputStream.write(FileOutputStream.java:257)
        at
java.io.BufferedOutputStream.flushBuffer(BufferedOutputStream.java:69)
        at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:127)
        at java.io.BufferedOutputStream.flush(BufferedOutputStream.java:128)
        at
org.apache.catalina.servlets.CGIServlet$CGIRunner.run(CGIServlet.java:1686)



---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message