tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mousami_bhattacha...@freddiemac.com
Subject RE: Problem Enabling SSL in Tomcat 4.1.27
Date Wed, 27 Oct 2004 18:01:07 GMT
Thanks Azam,
I tried your solution. But unfortunately , its still not working for me. I 
even put the .keystore file in the default user home directory. 
Is there some way to debug this issue ? 

Here's my tomcat server log ,
Oct 27, 2004 1:58:09 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 8080
Oct 27, 2004 1:58:10 PM org.apache.coyote.http11.Http11Protocol init
INFO: Initializing Coyote HTTP/1.1 on port 8443
Oct 27, 2004 1:58:19 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8080
Oct 27, 2004 1:58:19 PM org.apache.jk.common.ChannelSocket init
INFO: JK2: ajp13 listening on /0.0.0.0:8009
Oct 27, 2004 1:58:19 PM org.apache.jk.server.JkMain start
INFO: Jk running ID=0 time=21/50 
config=C:\tomcat4.1.27\jakarta-tomcat-4.1.27\conf\jk2.properties
Oct 27, 2004 1:58:19 PM org.apache.coyote.http11.Http11Protocol start
INFO: Starting Coyote HTTP/1.1 on port 8443






khanaz@HQ.Verizonwireless.com 
10/27/2004 01:39 PM
Please respond to
"Tomcat Users List" <tomcat-user@jakarta.apache.org>


To
tomcat-user@jakarta.apache.org
cc

Subject
RE: Problem Enabling SSL in Tomcat 4.1.27






Mousami:
I have a similar issue before.  What I did to resolve it was go through 
the
DOS command prompt and rename "mousami.keystore" to just ".keystore"
(Windows Explorer can't do it)

I am not sure as to why it wouldn't take the full file name but the
.keystore worked for me.

Good luck!

Azam Khan


-----Original Message-----
From: mousami_bhattacharya@freddiemac.com
[mailto:mousami_bhattacharya@freddiemac.com] 
Sent: Wednesday, October 27, 2004 1:34 PM
To: tomcat-user@jakarta.apache.org
Subject: Problem Enabling SSL in Tomcat 4.1.27 

Hi ,
I did the following steps to enable SSL in tomcat 4.1.27 ( with jdk 1.4.2)
1. uncommented the SSL Connector in the server.xml
    <!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
         <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
                   port="8443" minProcessors="5" maxProcessors="75"
                   enableLookups="true" 
                   acceptCount="10" debug="0" scheme="https" 
secure="true">
          <Factory 
className="org.apache.catalina.net.SSLServerSocketFactory"
                   clientAuth="false" protocol="TLS" 
 keystoreFile="C:\tomcat4.1.27\jakarta-tomcat-4.1.27\mousami.keystore" 
                   keystorePass="mm"/>
        </Connector>
2.  stored the keystore file in the directory mentioned.
3. started tomcat.
When I hit the url https://localhost:8443 , it seems like the browser is 
waiting. After waiting for sometime , it returns a "page cannot be found" 
error.
I dont see any error logs or any kind of exception , which can tell me 
what is going wrong.
Please help.
Thanks
Mousami Bhattacharya
The server.xml looks something like this :
<Service className="org.apache.catalina.core.StandardService" debug="0" 
name="Tomcat-Standalone">
    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
acceptCount="100" 
       bufferSize="2048" compression="off" connectionLinger="-1" 
connectionTimeout="20000" 
       connectionUploadTimeout="300000" debug="0" 
disableUploadTimeout="true" 
       enableLookups="true" maxKeepAliveRequests="100" maxProcessors="75" 
       minProcessors="5" port="8080" 
protocolHandlerClassName="org.apache.coyote.http11.Http11Protocol" 
       proxyPort="0" redirectPort="8443" scheme="http" secure="false" 
serverSocketTimeout="0" 
       tcpNoDelay="true" useURIValidationHack="false">
      <Factory 
className="org.apache.catalina.net.DefaultServerSocketFactory"/>
    </Connector>
    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
acceptCount="10" 
       bufferSize="2048" compression="off" connectionLinger="-1" 
connectionTimeout="0" 
       connectionUploadTimeout="300000" debug="0" 
disableUploadTimeout="false" enableLookups="true" 
       maxKeepAliveRequests="100" maxProcessors="75" minProcessors="5" 
port="8009" 
       protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler" 
proxyPort="0" 
       redirectPort="8443" scheme="http" secure="false" 
serverSocketTimeout="0" tcpNoDelay="true" 
       useURIValidationHack="false">
      <Factory 
className="org.apache.catalina.net.DefaultServerSocketFactory"/>
    </Connector>
    <!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
         <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
                   port="8443" minProcessors="5" maxProcessors="75"
                   enableLookups="true" 
                   acceptCount="10" debug="0" scheme="https" 
secure="true">
          <Factory 
className="org.apache.catalina.net.SSLServerSocketFactory"
                   clientAuth="false" protocol="TLS" 
 keystoreFile="C:\tomcat4.1.27\jakarta-tomcat-4.1.27\mousami.keystore" 
                   keystorePass="mm"/>
        </Connector>
 
....

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message