tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From mousami_bhattacha...@freddiemac.com
Subject Problem Enabling SSL in Tomcat 4.1.27
Date Wed, 27 Oct 2004 17:33:46 GMT
Hi ,
I did the following steps to enable SSL in tomcat 4.1.27 ( with jdk 1.4.2)

1. uncommented the SSL Connector in the server.xml
    <!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
         <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
                   port="8443" minProcessors="5" maxProcessors="75"
                   enableLookups="true" 
                   acceptCount="10" debug="0" scheme="https" 
secure="true">
          <Factory 
className="org.apache.catalina.net.SSLServerSocketFactory"
                   clientAuth="false" protocol="TLS" 
 keystoreFile="C:\tomcat4.1.27\jakarta-tomcat-4.1.27\mousami.keystore" 
                   keystorePass="mm"/>
        </Connector>

2.  stored the keystore file in the directory mentioned.
3. started tomcat.

When I hit the url https://localhost:8443 , it seems like the browser is 
waiting. After waiting for sometime , it returns a "page cannot be found" 
error.
I dont see any error logs or any kind of exception , which can tell me 
what is going wrong.

Please help.
Thanks
Mousami Bhattacharya


The server.xml looks something like this :

<Service className="org.apache.catalina.core.StandardService" debug="0" 
name="Tomcat-Standalone">
    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
acceptCount="100" 
       bufferSize="2048" compression="off" connectionLinger="-1" 
connectionTimeout="20000" 
       connectionUploadTimeout="300000" debug="0" 
disableUploadTimeout="true" 
       enableLookups="true" maxKeepAliveRequests="100" maxProcessors="75" 
       minProcessors="5" port="8080" 
protocolHandlerClassName="org.apache.coyote.http11.Http11Protocol" 
       proxyPort="0" redirectPort="8443" scheme="http" secure="false" 
serverSocketTimeout="0" 
       tcpNoDelay="true" useURIValidationHack="false">
      <Factory 
className="org.apache.catalina.net.DefaultServerSocketFactory"/>
    </Connector>
    <Connector className="org.apache.coyote.tomcat4.CoyoteConnector" 
acceptCount="10" 
       bufferSize="2048" compression="off" connectionLinger="-1" 
connectionTimeout="0" 
       connectionUploadTimeout="300000" debug="0" 
disableUploadTimeout="false" enableLookups="true" 
       maxKeepAliveRequests="100" maxProcessors="75" minProcessors="5" 
port="8009" 
       protocolHandlerClassName="org.apache.jk.server.JkCoyoteHandler" 
proxyPort="0" 
       redirectPort="8443" scheme="http" secure="false" 
serverSocketTimeout="0" tcpNoDelay="true" 
       useURIValidationHack="false">
      <Factory 
className="org.apache.catalina.net.DefaultServerSocketFactory"/>
    </Connector>

    <!-- Define a SSL Coyote HTTP/1.1 Connector on port 8443 -->
         <Connector className="org.apache.coyote.tomcat4.CoyoteConnector"
                   port="8443" minProcessors="5" maxProcessors="75"
                   enableLookups="true" 
                   acceptCount="10" debug="0" scheme="https" 
secure="true">
          <Factory 
className="org.apache.catalina.net.SSLServerSocketFactory"
                   clientAuth="false" protocol="TLS" 
 keystoreFile="C:\tomcat4.1.27\jakarta-tomcat-4.1.27\mousami.keystore" 
                   keystorePass="mm"/>
        </Connector>
 
....

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message