tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Cherichetti \(Renegade Internet\)" <m...@renegadeinternet.com>
Subject RE: Weird Red Hat Enterprise Startup
Date Wed, 13 Oct 2004 04:15:47 GMT
Hi Everyone,

Well, I finally solved this problem.  OS patches didn't do the trick, still
had segmentation faults and unexplained crashes on startup and shutdown, no
core dumps, no error messages, and -server band-aid didn't work for me
either (I was running out of options!).  The solution was to use the IBM JDK
instead of the Sun JDK.  If you're having the same problem and you don't
need Java 1.5/5.0 for a while, give the IBM JDK a shot, it worked for me.

Have a nice day ...

Sincerely,

Mike Cherichetti


-----Original Message-----
From: news [mailto:news@sea.gmane.org]On Behalf Of Shankar Unni
Sent: Monday, October 11, 2004 5:08 PM
To: tomcat-user@jakarta.apache.org
Subject: Re: Weird Red Hat Enterprise Startup


Shapira, Yoav wrote:

> Any JVM switch to make an internal JVM crash "disappear" is cruising for
> a bruising.

Fully understood.

> Most likely, it's missing OS-level patches for your system.

True, except that for the Linux case, we are running on one of the
supported OSes (RH EL 3.0WS, stock), and there's no mention of any
required patches for Linux. Still get the crash.

In our case, it was readily triggered by a particularly large output
from a JSP - a table with ~1500 rows, which was a pathological case -
and we have workarounds for this particular symptom.  But there have
been other unexplained crashes, too, and we have found open bugs in the
Sun JDC bug database referring to crashes like this on Linux..

So yes, once again: -server is a band-aid (just one of many), it's not
guaranteed to fix anything at all (could even make things worse) - it
just shifts the problem around under the blanket. It's just one thing to
try, and *if it "works" in your case*, use it as a temporary workaround.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org






---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message