tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anthony E. Carlos" <anth...@digitalphenom.com>
Subject mod_jk compatibility
Date Mon, 04 Oct 2004 04:13:51 GMT
Hello,

I have mod_jk working well with Apache 1.3.x and Tomcat 4.1.x. I'm 
trying to connect to a new Tomcat 5 instance (on a different port), but 
it doesn't work.

Here's a snippet from my server.xml on Tomcat 5:

     <!-- Define a Coyote/JK2 AJP 1.3 Connector on port 8019 -->
     <Connector port="8019"
                enableLookups="false" redirectPort="8443" debug="1"
                protocol="AJP/1.3" />

Here's what shows up in catalina.out:

Sep 30, 2004 1:00:26 AM org.apache.jk.common.MsgAjp processHeader
SEVERE: BAD packet signature 256
01 00 03 47 00 00 00 00 00 00 00 00 00 00 00 00  | ...G............
00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00  | ................
... (a lot more lines filled with 00s)


I thought mod_jk used AJP 1.3. Is it compatible in any way with Tomcat 
5?

BTW, I cannot use mod_jk2 because of my sysadmin's grumblings.

Thanks,

-Anthony Carlos


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message