tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Januski, Ken" <kjanu...@phillynews.com>
Subject RE: Problem with logging in Eclipse
Date Wed, 27 Oct 2004 17:29:24 GMT
This isn't much help but I have had a somewhat similar experience. I took
the war for a working application running on Tomcat 4.0 at work and tried to
get it running with Tomcat 5.0 and Eclipse 3.0 at home. It constantly
complained about not being able to find log4j, this no matter where I put
the log4j jar. Since this isn't something critical to me I haven't focussed
on solving it, but have been playing with it intermittently for at least 2
months. But it does seem odd to me that Tomcat in Eclipse can never find it.

You wouldn't think that log4j had to go in some special place in Eclipse. I
hope someone else can shed some light.


-----Original Message-----
From: Glenn Barnard [mailto:barnardglenn@hotmail.com]
Sent: Wednesday, October 27, 2004 11:11 AM
To: tomcat-user@jakarta.apache.org
Subject: Problem with logging in Eclipse


Hi, I'm new to this list so if my question has been answered previously, 
please give me a URL to look at---I have tried one without a hit.

I am trying to use Tomcat 5.5 in my Eclipse 3.0 development environment. I 
have a Tomcat plugin which starts Tomcat from a simple icon. In following 
the limited instructions I've been able to find for installing log4j for 
Tomcat 5.5, I put commons-logging.jar and log4j.jar in the common/lib 
directory. As soon as I do that, Tomcat fails during startup with the 
following stack trace. The messages indicate that Catalog.class is not in 
the jar files, but I've confirmed that it is in log4j.jar in the correct 
package.

I have brought in the source code, and tried to step through it, but I'm not

getting anywhere with that. This AM I tried Tomcat 5.0 and got the same 
problem. Am not seeing any problem starting Tomcat directly from a DOS 
prompt.

If anyone can help me, I'd surely appreciate it! Let me know if you have any

questions about how I configure Tomcat, although I've tried server.xml 
without editing it.

java.lang.ExceptionInInitializerError
	at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native
Method)
	at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown
Source)
	at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown

Source)
	at java.lang.reflect.Constructor.newInstance(Unknown Source)
	at java.lang.Class.newInstance0(Unknown Source)
	at java.lang.Class.newInstance(Unknown Source)
	at org.apache.catalina.startup.Bootstrap.init(Bootstrap.java:208)
	at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:402)
Caused by: org.apache.commons.logging.LogConfigurationException: 
org.apache.commons.logging.LogConfigurationException: No suitable Log 
constructor [Ljava.lang.Class;@958bb8 for 
org.apache.commons.logging.impl.Log4JLogger (Caused by 
java.lang.NoClassDefFoundError: org/apache/log4j/Category) (Caused by 
org.apache.commons.logging.LogConfigurationException: No suitable Log 
constructor [Ljava.lang.Class;@958bb8 for 
org.apache.commons.logging.impl.Log4JLogger (Caused by 
java.lang.NoClassDefFoundError: org/apache/log4j/Category))
	at 
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:543)
	at 
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:235)
	at 
org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.ja
va:209)
	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:351)
	at 
org.apache.catalina.core.StandardService.<clinit>(StandardService.java:53)
	... 8 more
Caused by: org.apache.commons.logging.LogConfigurationException: No suitable

Log constructor [Ljava.lang.Class;@958bb8 for 
org.apache.commons.logging.impl.Log4JLogger (Caused by 
java.lang.NoClassDefFoundError: org/apache/log4j/Category)
	at 
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:413)
	at 
org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.ja
va:529)
	... 12 more
Caused by: java.lang.NoClassDefFoundError: org/apache/log4j/Category
	at java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.lang.Class.privateGetDeclaredConstructors(Unknown Source)
	at java.lang.Class.getConstructor0(Unknown Source)
	at java.lang.Class.getConstructor(Unknown Source)
	at 
org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryI
mpl.java:410)
	... 13 more

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today - it's FREE! 
hthttp://messenger.msn.click-url.com/go/onm00200471ave/direct/01/


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message