tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Souther <bsout...@fwdco.com>
Subject Re: webapp hangs, how to debug?
Date Sun, 24 Oct 2004 15:41:02 GMT
I would start by adding print statements to the various parts of your
code and tailing the logs to see where exactly it's hanging.

I don't know anything about your app but the first thing I would look at
is how you're getting database connections.  If you are using connection
pooling and not returning connections your app would certainly hang once
you've reached the upper limit.  



On Sun, 2004-10-24 at 11:20, Alexio Cassani wrote:
> Hi all,
> I'm trying to debug a hanging problem raised by a web application that my
> company developed using Codecharge Studio.
> 
> The application has an usual architecture: it gets some data from an Oracle
> 9i db and show them in a few jsp pages.
> 
> The problem is present during the login phase: I put username and password
> in the right fields and then click the login button; usually the login is
> almost istantaneous, but sometimes it hangs and avoid me to go to the next
> page.
> 
> The same web app is installed in a staging server and here I have not
> reproduced the same error yet (I've tried with no result...); en fact the
> problem is only presents in the production environment (that is identical
> for hw and sw to the stage one but for the presence of 2 host in the
> front-end). 
> 
> All the log files existing (both from Tomcat than from Codecharge) are
> configured to shows all debug infos, and they doesn't report any errors.
> The memory footprint of Tomcat is below the upper limit of 1GB the I've
> configured. (the total amount of physical memory is 4GB)
> During the login the cpu is totally unloaded.
> 
> The operating system is RedHat AS and the kernel can manage since 14000
> threads (I've monitored also this param).
> Restarting tomcat solve the issue and in two situations the problem
> disappeared magically:
> 
> 1- the first time when I restarted a Jboss running in the same box
> 2- the second during my "log scouting" on the box the webapps started
> working fine without any action (I was only reading sys info in /proc
> directory)
> 
> As said before in the production environment are presents two Linux box in
> the front end and the web app presents the same problem on both servers.
> 
> Can someone suggest me where to look in order to pickpoint the problem?
> 
> TIA
> Alexio 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message