tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "spammemothers" <spammemoth...@yahoo.co.uk>
Subject RE: Does Oracle 9i thin jdbc driver work in Tomcat 5?
Date Sun, 24 Oct 2004 11:12:31 GMT
Please is anyone using Oracle 9 with tomcat 5? - I've really hit a brick
wall here & still have no idea if it's my fault or it just doesn't work!

I just want to setup a connection pool of Oracle 9 thin JDBC connections!

Thanks

harry

-----Original Message-----
From: spammemothers [mailto:spammemothers@yahoo.co.uk] On Behalf Of Adrian
Harrison
Sent: 23 October 2004 17:28
To: tomcat-user@jakarta.apache.org
Subject: Does Oracle 9i thin jdbc driver work in Tomcat 5?


using tomcat 5.0.28, oracle 9.2.1.0 on windows 2000 (sp4)

having a nightmare here, upgraded from oracle 8i to 9i, downloaded &
installed ojdbc14.jar file in Tomcat's common\lib directory.

Now all I get when trying to create a connection pool is this exception -

2004-10-22 17:04:22 StandardContext[/PRD]action: null
java.lang.NullPointerException
   at
org.apache.commons.dbcp.DelegatingConnection.close(DelegatingConnection.java
:151)
   at
org.apache.commons.dbcp.PoolableConnection.reallyClose(PoolableConnection.ja
va:95)
   at
org.apache.commons.dbcp.PoolableConnectionFactory.destroyObject(PoolableConn
ectionFactory.java:301)
   at
org.apache.commons.dbcp.BasicDataSource.validateConnectionFactory(BasicDataS
ource.java:883)
   at
org.apache.commons.dbcp.BasicDataSource.createDataSource(BasicDataSource.jav
a:851)
etc...

from my web.xml file -

<resource-ref>
 <description>Oracle Datasource example</description>
<res-ref-name>PRDConnectionPool</res-ref-name>
 <res-type>javax.sql.DataSource</res-type>
 <res-auth>Container</res-auth>
</resource-ref>

from my app xml file -

   <parameter>
     <name>factory</name>
     <value>org.apache.commons.dbcp.BasicDataSourceFactory</value>
   </parameter>
   <parameter>
     <name>driverClassName</name>
     <value>oracle.jdbc.driver.OracleDriver</value>
   </parameter>
   <parameter>
     <name>url</name>
     <value>jdbc:oracle:thin:prd_owner@127.0.0.1:1521:dev91</value>
   </parameter>

Worked fine under 8.1i but now I've hit a brick wall with this one - is it
possible to get these to work together?

Probably doing something really stupid, any ideas?

many thanks

harry





---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message