tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Patrick Burleson <pburle...@gmail.com>
Subject Re: Log4J in Tomcat 5.0...I don't believe the FAQ
Date Mon, 06 Sep 2004 05:31:20 GMT
Thanks for that, but that's not exactly what I am asking for. I know
that putting log4j into my webapp will work. What I want to do is to
have Tomcat *itself* use log4j for logging statements. The messages I
linked to say that it's very simple to do. Yet following the
instructions, it doesn't work here.

Thanks,
Patrick


On Sun, 5 Sep 2004 21:01:21 +0200, Pedro Nevado <pnevado@javato.com> wrote:
> In case it helps, this is what I do with Tomcat 5.0.28 (Win 2000 without
> installer, j2sdk1.4.2_04):
> - I do not put log4j.jar in commom/lib, but in the WEB-INF/lib of my web
> app.
> - I put log4j.xml (equivalent to log4j.properties) and
> commons-logging.properties in WEB-INF/classes of my app.
> The archive commons-logging.properties contains:
> 
> org.apache.commons.logging.Log=org.apache.commons.logging.impl.Log4JLogger
> 
> I use the commons-logging api in my application classes.
> 
> Regards.
> Pedro Nevado
> 
> -----Mensaje original-----
> De: Patrick Burleson [mailto:pburleson@gmail.com]
> Enviado el: domingo, 05 de septiembre de 2004 17:05
> Para: tomcat-user@jakarta.apache.org
> Asunto: Log4J in Tomcat 5.0...I don't believe the FAQ
> 
> 
> 
> 
> So I'm trying to get Tomcat 5.0 to use Log4J for its log output
> formatted to my liking. Started searching and found a link to this
> message in the Tomcat FAQ that says it has the solution.
> 
> http://marc.theaimsgroup.com/?l=tomcat-user&m=108330970225012&w=2
> 
> Well, after performing what seem like simple steps (probably the steps
> I would have done anyway), still no logging through Log4J.
> 
> Did I miss some magically step number 4 or even step 0? I copied
> log4j-1.2.8.jar to <CATALINA>/commons/lib and put the example
> log4j.properties in <CATALINA>/commons/classes at DEBUG level and
> still only got the original format with only INFO level stuff printing
> out.
> 
> I tried with the following versions of Tomcat on Windows XP with JDK
> 1.4.2_05 and JDK 5.0-RC:
> 
> 5.0.27 Windows Installer
> 5.0.27 Zip file
> 5.0.19 Windows Installer
> 5.0.19 Zip File
> 
> I tried the last two since they were the version mention in the mail
> message. I tried the zips thinking maybe there was something
> "different" about the windows installers.
> 
> Later in that thread it is mentioned by Jacob Kjome in message
> http://marc.theaimsgroup.com/?l=tomcat-user&m=108333554729166&w=2 :
> 
> " I've pointed out almost these exact instructions many times before
> and people keep asking or say it doesn't work (it does)."
> 
> I just don't believe it. There has to be something I missed...but
> that's hard to do when there's only 3 steps, one of them being
> "Download Log4J".
> 
> Any ideas?
> 
> Thanks,
> Patrick
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message