tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Reza Ferrydiansyah <rezafe...@gmail.com>
Subject Xalan problem :(
Date Tue, 07 Sep 2004 20:24:38 GMT
Hi all,

I'm using jdk1.5rc with tomcat 5.0.27 on windows 2003 server

This line from one of my classes (inside
WEB-INF/classes/myPackage/myClass.java) gives me an error as follows:
TransformerFactory tFactory = TransformerFactory.newInstance();

javax.xml.transform.TransformerFactoryConfigurationError: Provider
org.apache.xalan.processor.TransformerFactoryImpl not found
	javax.xml.transform.TransformerFactory.newInstance(Unknown Source)

I have the source of the jdk1.5rc and looking at the source
org.apache.xalan.processor.TransformerFactoryImpl does not exist. (to
be exact it is com.sun.org.apache.xalan... )

Looking at the TransformerFactory newInstance method I can't help to
notice that they try to look for

public static TransformerFactory newInstance()
        throws TransformerFactoryConfigurationError {
        try {
            return (TransformerFactory) FactoryFinder.find(
            /* The default property name according to the JAXP spec */
            "javax.xml.transform.TransformerFactory",
            /* The fallback implementation class name, XSLTC */
            "com.sun.org.apache.xalan.internal.xsltc.trax.TransformerFactoryImpl");
             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
        } catch (FactoryFinder.ConfigurationError e) {

which makes me believe that xalan has been changed for jdk1.5rc? Is that right?

So I did a little experiment. I created a java program which all it
does is create a newInstance of the TransformerFactory. That is its
main function consists of :
TransformerFactory tFactory = TransformerFactory.newInstance();

Compiled it with jdk1.5rc, executed it and it works fine. So the
question is why does the program work when I execute it via command
line (using javac, and java) but not with the tomcat. Tomcat should
use the same library as the one in java right? Of course the biggest
question is how do I make my program work...

Additional information. This program is done in a new server. That is
there is no previous versions of the jdk nor previous version of
tomcat.

Thank you.

-- 
--
Reza Ferrydiansyah
http://www.informatika.org/~reza

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message