tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex <a...@squigly.net>
Subject segmentation faults with jk2 w/ apache 2.0.50 and jakarta-tomcat-5.0.18/24
Date Fri, 10 Sep 2004 09:25:48 GMT

First i'll describe the environment:

[environment]
Linux monkeyboy 2.4.20-20.9 #1 Mon Aug 18 11:45:58 EDT 2003 i686 i686 i386 GNU/Linux

apache-2.0.50 with the following options:
"--enable-so" \
"--enable-http" \


jakarta-tomcat-connectors-jk2-2.0.4-src compiled with the following:
--with-jni --with-apxs2=/opt/apache-2.0.50/bin/apxs
--with-apache2=/usr/local/src/httpd-2.0.50 --with-java-home=/usr/local/jdk

cd ../build/jk2/apache2/
/opt/apache-2.0.50/bin/apxs -n jk2 -i mod_jk2.so

Which gives the output:
/opt/apache-2.0.50/build/instdso.sh SH_LIBTOOL='/opt/apache-2.0.50/build/libtool' mod_jk2.so
/opt/apache-2.0.50/modules
/opt/apache-2.0.50/build/libtool --mode=install cp mod_jk2.so
/opt/apache-2.0.50/modules/
cp mod_jk2.so /opt/apache-2.0.50/modules/mod_jk2.so
Warning!  dlname not found in /opt/apache-2.0.50/modules/mod_jk2.so.
Assuming installing a .so rather than a libtool archive.
chmod 755 /opt/apache-2.0.50/modules/mod_jk2.so

app server:
resides on another machine.  i have both 5.0.24 and 5.0.18 running (not at
the same time -- using the same port).  I can verify that the ajp13 works
as i can yield results using the isapi dll with iis5.0

[problem]

Right, so from the above, I've compiled and installed apache.  That works.
No problems there.  Compile and deploy the mod_jk2.so file.  I modify the
httpd.conf and add some virtual hosts.  Those work.  Tested.  I then
modify the one virtual host with the following:

        <Location "/jsp-dev/*.jsp">
                JkUriSet worker ajp13:thinktank
        </Location>

The workers2.properties file has the following:

[logger.apache2]
level=DEBUG

[shm]
file=/opt/apache-2.0.50/logs/shm.file
size=1048576

[channel.socket:thinktank]
port=8009
host=10.10.12.14
type=ajp13

# define the worker
[ajp13:thinktank]
channel=channel.socket:thinktank

When I attempt to go to http://test1/jsp-dev/hello-world.jsp I get the
following below in the error log for apache.


[Thu Sep 09 15:28:47 2004] [notice] Apache/2.0.50 (Unix) mod_jk2/2.0.4 configured -- resuming
normal operations
[Thu Sep 09 15:28:55 2004] [notice] jk2_init() Setting scoreboard slot 0 for child 9912
[Thu Sep 09 15:28:55 2004] [notice] channelApr.resolve(): create AF_NET 10.10.12.14 8009
[Thu Sep 09 15:28:55 2004] [notice] workerEnv.init() ok /opt/apache-2.0.50/conf/workers2.properties
[Thu Sep 09 15:28:55 2004] [notice] mod_jk2 child 9912 initialized
[Thu Sep 09 15:28:55 2004] [notice] child pid 9907 exit signal Segmentation fault (11)
[Thu Sep 09 15:28:57 2004] [notice] jk2_init() Setting scoreboard slot 0 for child 9913
[Thu Sep 09 15:28:57 2004] [notice] channelApr.resolve(): create AF_NET  10.10.12.14 8009
[Thu Sep 09 15:28:57 2004] [notice] workerEnv.init() ok /opt/apache-2.0.50/conf/workers2.properties
[Thu Sep 09 15:28:57 2004] [notice] mod_jk2 child 9913 initialized
[Thu Sep 09 15:28:57 2004] [notice] child pid 9908 exit signal Segmentation fault (11)

If i go to http://10.10.12.14:8080/jsp-dev/hello-world.jsp it yields up
the expected jsp.  Is there anyway or anything I can do to allow me to
trouble shoot this more?  I'm not given any context anywhere that I can
find to troubleshoot that segmentation fault.  If i switch it to a tomcat
5.0.24 instance, I get the same results.

Any help would be appreciated.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message