tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Václavík Radek <Radek.Vacla...@zentiva.cz>
Subject RE: XLT file won't open in associated application (Excel)
Date Thu, 30 Sep 2004 06:34:13 GMT
Hi,
I am asking for it as a static resource, therefore I have no way to modify
the response in servlet. But if I don't get this solved, I probably have to
do it through servlet...

Radek

> -----Original Message-----
> From: Shapira, Yoav [mailto:Yoav.Shapira@mpi.com]
> Sent: Wednesday, September 29, 2004 2:31 PM
> To: Tomcat Users List
> Subject: RE: XLT file won't open in associated application (Excel)
> 
> 
> 
> Hi,
> When you do the download, are you streaming it yourself from 
> a servlet, or asking for it as a static resource?  If the 
> former, you should use the http-equiv content-disposition header.
> 
> Yoav Shapira
> Millennium Research Informatics
> 
> 
> >-----Original Message-----
> >From: Václavík Radek [mailto:Radek.Vaclavik@zentiva.cz]
> >Sent: Wednesday, September 29, 2004 4:52 AM
> >To: 'tomcat-user@jakarta.apache.org'
> >Subject: XLT file won't open in associated application (Excel)
> >
> >Hi all,
> >
> >I am trying to download an XLT (Excel template) file from 
> Tomcat server,
> >but
> >instead of running excel and opening the file, browser (IE 
> 6) shows the
> >file
> >in binary.
> >
> >I have tried setting the MIME mapping in web.xml for this 
> site such as:
> >  <mime-mapping>
> >        <extension>xlt</extension>
> >        <mime-type>application/vnd.ms-excel</mime-type>
> >  </mime-mapping>
> >
> >(I have tried also "msexcel", "excel"). But I still can't 
> get the browser
> >to
> >run Excel.
> >
> >When I put the same file onto MS IIS server and try to 
> download it, Excel
> >runs and opens the file correctly. I have inspected HTTP requests and
> >responses from both servers and found no relevant difference.
> >
> >I also have similar problem with dot file type (MS Word 
> document template).
> >I have added the following to web.xml:
> >
> >  <mime-mapping>
> >        <extension>dot</extension>
> >        <mime-type>application/msword</mime-type>
> >  </mime-mapping>
> >
> >and when I run the Tomcat server on localhost while 
> developing, this works
> >fine and runs Word. But when I deploy the application to 
> production Tomcat
> >server, Word is not run and binary file is displayed again. 
> With dot file
> >type this does not work in either case (as mentioned above).
> >
> >
> >I am using Tomcat 5.0.12 for developing and 5.0.19 for production.
> >
> >
> >Thanks for possible solutions.
> >
> >
> >Radek
> >
> >_____________________________
> >
> >Ing. Radek Václavík
> >ICS Department - webmaster
> >
> >ZeNTIVA a.s.
> >U Kabelovny 130, 102 37 Praha 10
> >Czech Republic
> >tel. +420 267 243 296
> >_____________________________
> 
> 
> 
> 
> This e-mail, including any attachments, is a confidential 
> business communication, and may contain information that is 
> confidential, proprietary and/or privileged.  This e-mail is 
> intended only for the individual(s) to whom it is addressed, 
> and may not be saved, copied, printed, disclosed or used by 
> anyone else.  If you are not the(an) intended recipient, 
> please immediately delete this e-mail from your computer 
> system and notify the sender.  Thank you.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message