tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shapira, Yoav" <Yoav.Shap...@mpi.com>
Subject RE: TLS-Enabled Connector Prevents Startup
Date Tue, 07 Sep 2004 13:27:17 GMT

Hi,
Is there any additional debug output in the logger, specifically a
ClassNotFoundException or a NoClassDefFoundError for a TLS-related
class?  Has the JVM you're using changed?

Yoav Shapira
Millennium Research Informatics


>-----Original Message-----
>From: Igor Zlatkovic [mailto:igor@zlatkovic.com]
>Sent: Sunday, September 05, 2004 10:16 AM
>To: tomcat-user@jakarta.apache.org
>Subject: TLS-Enabled Connector Prevents Startup
>
>Hi there.
>
>On one day, an otherwise perfectly functioning Tomcat stops responding
>to requests. The log file says that one of the threads received an
>OutOfMemory exception, so I restart the server. Not a big deal, it has
>happened before. But this time the server never comes up, it hangs
>somewhere.
>
>Some experimentation has shown that it works again if I remove the
>TLS-enabled connector from the conf/server.xml file. I have two
>connectors there, one for HTTP, the other for HTTPS. Both worked good
>until this last crash. Now, for some mysterious reason, if the HTTPS
>connector is present, the startup of Tomcat shows the following
messages:
>
>   Sep 4, 2004 5:21:12 PM org.apache.coyote.http11.Http11Protocol init
>   INFO: Initializing Coyote HTTP/1.1 on http-80
>
>and there it stops. The port 80 is opened for listening but noone
>answers when you ring there. According to previous good starts, I
should
>see another two lines just like those above, related to the port 443.
>Since the container hangs just before it should have printed them, I
>commented out the TLS-enabled connector and Tomcat started.
>
>What else can I say? The actual port numbers don't matter, I tried
>several with the same result. TLS worked perfectly before the crash and
>the configuration hasn't changed in between. It was Tomcat 5.0.25, I
>downloaded the fresh 5.0.28 and had the same result. I installed 5.0.28
>on my workstation, copied the configuration files from the server and
>voila, everything works here. Now I have two identical installations,
>the same configuration, the same keystore, the same Java VM, and on the
>workstation I see it working, but on the server it hangs unless I
>disable the TLS connector in conf/server.xml. The weirdest thing is,
>this TLS connector has worked on that very server for several months
>now, since the 5.0.18 release. I don't know wether it matters, the
>server is a vServer, means it shares hardware with other virtual
>servers. It shouldn't matter though, because I allready had this
>configuration working there.
>
>Does anyone have any idea?
>
>Ciao,
>Igor Zlatkovic
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
>For additional commands, e-mail: tomcat-user-help@jakarta.apache.org




This e-mail, including any attachments, is a confidential business communication, and may
contain information that is confidential, proprietary and/or privileged.  This e-mail is intended
only for the individual(s) to whom it is addressed, and may not be saved, copied, printed,
disclosed or used by anyone else.  If you are not the(an) intended recipient, please immediately
delete this e-mail from your computer system and notify the sender.  Thank you.


---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message