tomcat-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jonathan Rengifo <jmreng...@gmail.com>
Subject Re: Fatal: relocation error: file libapr-0.so.0: symbol __divdi3: referenced symbol not found
Date Fri, 03 Sep 2004 14:44:13 GMT
Hi all...

I ran the ldd utility on the jni dynamic library "libjkjni.so" with
the following results:

ldd libjkjni.so 
        libcrypt_i.so.1 =>       /usr/lib/libcrypt_i.so.1
        libapr-0.so.0 =>        
/usr/local/apache-httpd-2.0.50/lib/libapr-0.so.0
        libc.so.1 =>     /usr/lib/libc.so.1
        libgen.so.1 =>   /usr/lib/libgen.so.1
        libsendfile.so.1 =>      /usr/lib/libsendfile.so.1
        librt.so.1 =>    /usr/lib/librt.so.1
        libm.so.1 =>     /usr/lib/libm.so.1
        libsocket.so.1 =>        /usr/lib/libsocket.so.1
        libnsl.so.1 =>   /usr/lib/libnsl.so.1
        libresolv.so.2 =>        /usr/lib/libresolv.so.2
        libpthread.so.1 =>       /usr/lib/libpthread.so.1
        libdl.so.1 =>    /usr/lib/libdl.so.1
        libaio.so.1 =>   /usr/lib/libaio.so.1
        libmd5.so.1 =>   /usr/lib/libmd5.so.1
        libmp.so.2 =>    /usr/lib/libmp.so.2
        /usr/platform/SUNW,Sun-Fire-V210/lib/libc_psr.so.1
        libthread.so.1 =>        /usr/lib/libthread.so.1
        /usr/platform/SUNW,Sun-Fire-V210/lib/libmd5_psr.so.1


I notice that the library suposed to have the problem was there
"/usr/local/apache-httpd-2.0.50/lib/libapr-0.so.0" so I ran "nm"
utility on it with the following results:

nm /usr/local/apache-httpd-2.0.50/lib/libapr-0.so.0 | grep div
[337]   |         0|       0|FUNC |GLOB |0    |UNDEF  |.div
[640]   |         0|       0|FUNC |GLOB |0    |UNDEF  |.udiv
[909]   |         0|       0|NOTY |GLOB |0    |UNDEF  |__divdi3
[938]   |         0|       0|NOTY |GLOB |0    |UNDEF  |__udivdi3

So it seems that the problem is on the libapr-0.so.0.... because there
is the variable "__divdi3" wich is reporting the relocation error

One more thing, the Apache2 and the JK2 connector was configured and
make by me on box..

Thanks all... Any comments would be very helpful

Regards

Jonathan




On Fri, 03 Sep 2004 09:13:58 -0400, John Villar
<john.villar@florhard.com> wrote:
> 
> >1-Sep-2004 1:46:26 PM org.apache.jk.common.ChannelSocket init
> >INFO: JK2: ajp13 listening on /0.0.0.0:8009
> >
> >
> These two lines say that the JK2 connector has started normally.... it
> seems to me that the problem isn't on the java side
> 
> >ld.so.1: /usr/java/bin/java: fatal: relocation error: file
> >/usr/local/apache-httpd-2.0.50/lib/libapr-0.so.0: symbol __divdi3:
> >referenced symbol not found
> >
> >
> Here's the problem..... first things first..... find what libraries do
> uses "libapr", then try to see if all the files are in your path, use
> the which command, or was it whereis? :-S
> 
> >This causes tomcat not to start, I don't really know what to do about
> >this. I read some forum posted message about the "symbol __divdi3:
> >referenced symbol not found" and they said this is because of some
> >glibc 2.0 stuff, but didn't find any solution to this…
> >
> >
> certainly, Solaris is a real pain with the glibc issue.... try to
> compile apache from source in that box....
> 
> --
> John Villar
> Gerente de Proyectos
> Computadores Flor Hard Soft 2058 C.A.
> www.florhard.com
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
> For additional commands, e-mail: tomcat-user-help@jakarta.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: tomcat-user-unsubscribe@jakarta.apache.org
For additional commands, e-mail: tomcat-user-help@jakarta.apache.org


Mime
View raw message